activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ajitgirish <ajit_gir...@infosys.com>
Subject Active MQ 5.3 not starting up when migrated from ActiveMq 5.2.
Date Fri, 13 Nov 2009 06:37:38 GMT

Hi,

I am facing one issue when we migrate our application from ActiveMq5.2 to
ActiveMq5.3. 

We are using the same configuration xml file that we used for the earlier
version.

With the older version the broker used to start without any issues , but
with the latest version the Mq is not getting started. In the 'activemq.log'
logs i am getting the following message:-

2009-11-08 14:56:44,706 [erSimpleAppMain] DEBUG XBeanBrokerFactory            
- Now attempting to figure out the type of resource:
file:/home/dg/sorter/activemq/conf/sorter.xml


I am attaching the 'activemq-wrapper.log' which I captured while I tried
starting the ActiveMq broker.



Also pasting the content of the Configuration file below:-
beans
  xmlns="http://www.springframework.org/schema/beans"
  xmlns:amq="http://activemq.org/config/1.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
  http://activemq.org/config/1.0
http://activemq.apache.org/schema/activemq-core.xsd
  http://activemq.apache.org/camel/schema/spring
http://activemq.apache.org/camel/schema/spring/camel-spring.xsd">

  <!-- Allows us to use system properties as variables in this configuration
file -->
  <bean
class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer"/>

  <!-- Broker configuration -->
  <broker xmlns="http://activemq.org/config/1.0"
          brokerName="${activemq.host}"
          dataDirectory="${activemq.base}/data"
          advisorySupport="false">

    <!-- The transport connectors ActiveMQ will listen to -->
    <transportConnectors>
      <transportConnector name="stomp"   uri="stomp://localhost:61613"/>
      <transportConnector name="openwire"
uri="tcp://localhost:61616?wireFormat.maxInactivityDuration=-1"/>
      <transportConnector name="ssl"
uri="ssl://localhost:61619?wireFormat.maxInactivityDuration=-1"/>
    </transportConnectors>

    <!-- The memory usage -->
    <systemUsage>
      <systemUsage>
        <memoryUsage>
          <memoryUsage limit="512 mb" percentUsageMinDelta="20"/>
        </memoryUsage>
      </systemUsage>
    </systemUsage>

    <!-- The JMX configuration -->
    <managementContext>
      <managementContext connectorPort="1099"
jmxDomainName="org.apache.activemq"/>
    </managementContext>

    <!-- destination policy configuration -->
    <destinationPolicy>
      <policyMap>
        <policyEntries>
          <policyEntry topic=">" producerFlowControl="false"/>
          <policyEntry queue=">" producerFlowControl="false"/>
        </policyEntries>
      </policyMap>
   </destinationPolicy>

  </broker>

  <!-- An embedded servlet engine for serving up the Admin console -->
  <jetty xmlns="http://mortbay.com/schemas/jetty/1.0">
    <connectors>
      <nioConnector port="8161"/>
    </connectors>
    <handlers>
      <webAppContext contextPath="/admin"
resourceBase="${activemq.base}/webapps/admin"/>
    </handlers>
  </jetty>

</beans>


Is there any modification that is required to run the latest version of
ActiveMq in the configuration file.

Please advice.

Thanks ,
Ajit
-- 
View this message in context: http://old.nabble.com/Active-MQ-5.3-not-starting-up-when-migrated-from-ActiveMq-5.2.-tp26332080p26332080.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message