activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From thinkbox <pat_...@yahoo.com>
Subject ActiveMQ-CPP client connecting to an embedded ActiveMQ in JBoss
Date Mon, 09 Nov 2009 07:58:27 GMT

Hi All,

I have followed the tutorial found at 
http://activemq.apache.org/integrating-apache-activemq-with-jboss.html
Integrating ActiveMQ with JBoss . I was able to successfully test the
integration with the examples included with the ActiveMQ distribution.

I am using ActiveMQ-CPP in order to use my C++ codes as JMS clients and I
used ActiveMQ as the message broker. I was able to successfully create and
connect a Java code as a producer and a C++ code as a consumer and vice
versa. In this situation, ActiveMQ was started as stand-alone application by
using the script found in the bin folder of the ActiveMQ distribution.

However, when I tried to use and start JBoss with ActiveMQ embedded on it,
my C++ clients was not able to connect to the ActiveMQ (or JBoss ?). There
are no messages being produced or consumed. The C++ codes I used are those
in the example folder included with ActiveMQ-CPP distribution.

JBoss is installed on a Windows machine and my C++ codes are on a Unix
machine which are connected via LAN.

Any idea why messages are successfully produced and consumed when using
ActiveMQ as standalone but fails when using JBoss with embedded ActiveMQ?

- Pat
-- 
View this message in context: http://old.nabble.com/ActiveMQ-CPP-client-connecting-to-an-embedded-ActiveMQ-in-JBoss-tp26262449p26262449.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message