activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benoitx <beno...@yahoo.com>
Subject 5.2 config not working with 5.3
Date Thu, 05 Nov 2009 10:49:30 GMT

Hi

I've just tried to upgrade to 5.3 and I do not have any communication
between 2 servers under Unix (seems ok under XP).

The installation was working ok with 5.2 (except for large files split in
multi messages).

I have JBoss with embedded ActiveMQ listening on port 27000
I have Mule with embedded ActiveMQ listening on port 28000; both static tcp.

Both running on the same Solaris machine (called speedy)

I'd be extremely grateful if someone could make a suggestion...

I'm more than happy to help debugging if required...

I now get this with DEBUG level on the Mule log which is trying to send
something to JBoss:
(more config info below)

2009-11-05 10:32:12,356 WARN  [network.DiscoveryNetworkConnector#?] (Simple
Discovery Agent: java.util.concurrent.ThreadPoolExecutor$Worker@e0ada6:)
Could not start network bridge between: vm://appendium-esb-server and:
tcp://speedy:28000 due to: java.net.ConnectException: Connection refused
2009-11-05 10:32:12,356 DEBUG [network.DiscoveryNetworkConnector#?] (Simple
Discovery Agent: java.util.concurrent.ThreadPoolExecutor$Worker@e0ada6:)
Start failure exception: java.net.ConnectException: Connection refused
java.net.ConnectException: Connection refused
	at java.net.PlainSocketImpl.socketConnect(Native Method)
	at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
	at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
	at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
	at java.net.Socket.connect(Socket.java:519)
	at
org.apache.activemq.transport.tcp.TcpTransport.connect(TcpTransport.java:435)
	at
org.apache.activemq.transport.tcp.TcpTransport.doStart(TcpTransport.java:401)
	at org.apache.activemq.util.ServiceSupport.start(ServiceSupport.java:53)
	at
org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:57)
	at
org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:57)
	at
org.apache.activemq.transport.WireFormatNegotiator.start(WireFormatNegotiator.java:72)
	at
org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:57)
	at
org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:57)
	at
org.apache.activemq.network.DemandForwardingBridgeSupport.start(DemandForwardingBridgeSupport.java:225)
	at
org.apache.activemq.network.DiscoveryNetworkConnector.onServiceAdd(DiscoveryNetworkConnector.java:130)
	at
org.apache.activemq.transport.discovery.simple.SimpleDiscoveryAgent$1.run(SimpleDiscoveryAgent.java:164)
	at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:619)
2009-11-05 10:32:12,356 DEBUG [simple.SimpleDiscoveryAgent#?] (Simple
Discovery Agent: java.util.concurrent.ThreadPoolExecutor$Worker@8c39d7:)
Failure occured soon after the discovery event was generated.  It will be
clasified as a connection failure:
org.apache.activemq.transport.discovery.simple.SimpleDiscoveryAgent$SimpleDiscoveryEvent@7bacb
2009-11-05 10:32:12,356 DEBUG [simple.SimpleDiscoveryAgent#?] (Simple
Discovery Agent: java.util.concurrent.ThreadPoolExecutor$Worker@8c39d7:)
Waiting 8000 ms before attepting to reconnect.
2009-11-05 10:32:20,364 INFO  [network.DiscoveryNetworkConnector#?] (Simple
Discovery Agent: java.util.concurrent.ThreadPoolExecutor$Worker@8c39d7:)
Establishing network connection from vm://appendium-esb-server to
tcp://speedy:28000
2009-11-05 10:32:20,366 DEBUG [tcp.TcpTransport#?] (Simple Discovery Agent:
java.util.concurrent.ThreadPoolExecutor$Worker@8c39d7:) Stopping transport
tcp://null:0
2009-11-05 10:32:20,366 WARN  [network.DiscoveryNetworkConnector#?] (Simple
Discovery Agent: java.util.concurrent.ThreadPoolExecutor$Worker@8c39d7:)
Could not start network bridge between: vm://appendium-esb-server and:
tcp://speedy:28000 due to: java.net.ConnectException: Connection refused
2009-11-05 10:32:20,366 DEBUG [network.DiscoveryNetworkConnector#?] (Simple
Discovery Agent: java.util.concurrent.ThreadPoolExecutor$Worker@8c39d7:)
Start failure exception: java.net.ConnectException: Connection refused
java.net.ConnectException: Connection refused
	at java.net.PlainSocketImpl.socketConnect(Native Method)
	at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
	at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
	at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
	at java.net.Socket.connect(Socket.java:519)
	at
org.apache.activemq.transport.tcp.TcpTransport.connect(TcpTransport.java:435)
	at
org.apache.activemq.transport.tcp.TcpTransport.doStart(TcpTransport.java:401)
	at org.apache.activemq.util.ServiceSupport.start(ServiceSupport.java:53)
	at
org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:57)
	at
org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:57)
	at
org.apache.activemq.transport.WireFormatNegotiator.start(WireFormatNegotiator.java:72)
	at
org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:57)
	at
org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:57)
	at
org.apache.activemq.network.DemandForwardingBridgeSupport.start(DemandForwardingBridgeSupport.java:225)
	at
org.apache.activemq.network.DiscoveryNetworkConnector.onServiceAdd(DiscoveryNetworkConnector.java:130)
	at
org.apache.activemq.transport.discovery.simple.SimpleDiscoveryAgent$1.run(SimpleDiscoveryAgent.java:164)
	at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:619)
2009-11-05 10:32:20,366 DEBUG [simple.SimpleDiscoveryAgent#?] (Simple
Discovery Agent: java.util.concurrent.ThreadPoolExecutor$Worker@e0ada6:)
Failure occured soon after the discovery event was generated.  It will be
clasified as a connection failure:
org.apache.activemq.transport.discovery.simple.SimpleDiscoveryAgent$SimpleDiscoveryEvent@7bacb


In Mule activemq-broker-config xml, I have:

<transportConnectors>
   <transportConnector uri="tcp://speedy:27000" />
</transportConnectors>

and
<networkConnector name="appendium-esb-server-to-jboss-server"
uri="static:(tcp://speedy:28000)" dynamicOnly="true">
	<dynamicallyIncludedDestinations>
		<!-- Only propagate those queues for consumers only -->
		<queue physicalName="queue.XXXXX" />
	</dynamicallyIncludedDestinations>
</networkConnector>


The JBoss config is in an RAR inside the EAR
with activeio-core-3.1.0.jar (is this the correct version? Do I need this?)
and activemq-core-5.3.0.jar and activemq-ra-5.3.0.jar
xbean-spring-3.4.jar

the JBoss broker config is:
<transportConnectors>
    <transportConnector uri="tcp://${server.host}:${amq.transportPort}" />
</transportConnectors>

<networkConnectors>
   <networkConnector name="appendium-jboss-server-to-esb-server"
uri="static://(tcp://${esb.server.host}:${esb.server.amq.transportPort})"
dynamicOnly="true">
	<dynamicallyIncludedDestinations>
		<!-- We explicitly include these IF there is a listener on the other side.
-->
		<queue physicalName="queue.YYYY" />
	</dynamicallyIncludedDestinations>
</networkConnector>

JBoss is started with 
server.host=speedy
amq.transportPort=28000
esb.server.host=speedy
esb.server.amq.transportPort=27000

Am I missing something in my config?

Has something dramatically changed between 5.2 and 5.3?

Many thanks

Benoit





-----
Thanks & Regards,

Benoit

http://www.Appendium.com   http://objectlab.blogspot.com

-- 
View this message in context: http://old.nabble.com/5.2-config-not-working-with-5.3-tp26210281p26210281.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message