activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bpmuser <brian.mckin...@nrc.ca>
Subject Re: ActiveMq-Cpp soConnectTimeout not working
Date Wed, 04 Nov 2009 20:00:58 GMT



Timothy Bish wrote:
> 
> On Wed, 2009-11-04 at 08:50 -0800, bpmuser wrote:
> The failover transport is going to keep trying to reconnect here even if
> the soConnectTimeout causes the attempt to connect to fail.  Have you
> tried without the failover transport in the mix to see if
> soConnectTimeout is working?  
> 
> tcp://127.0.0.1:61616?soConnectTimeout=1
> 
> If you are looking for a way to have the connection fail when using the
> Failover transport then you'd probably want to set the
> maxReconnectAttempts value on the Failover transport as follows.
> 
> failover:(tcp://127.0.0.1:61616?soConnectTimeout=1)?maxReconnectAttempts=50
> 
> Regards
> Tim.
> 
> 

Removing failover worked, but adding maxReconnectAttemps to the failover put
me into a lock again.  

I started using failover since my program was disconnecting after a minute
of inactivity.  Is there a way to check the connection status and restore
lost connections without the failover? Or is there a way to stop the
disconnect after a minute of inactivity?

Cheers,
Brian!
-- 
View this message in context: http://old.nabble.com/ActiveMq-Cpp-soConnectTimeout-not-working-tp26200045p26203654.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message