activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: How to configure failover for jmsBridgeConnector
Date Fri, 16 Oct 2009 09:54:39 GMT
note that the failover transport of part of the activemq client, it will not
work with OpenJMS. There is currently no facility to retry jms connections
to a foreign provider by the ActiveMQ JMS bridge.
Could you open a jira[1] enhancement, describing your use case, to track
this. It is something we should implement. Essentially some configurable
retry logic in the event that JMS exception ocurrs on the foreign end of a
bridge.

[1]
http://activemq.apache.org/contributing.html#Contributing-Ifyoufindabugorproblem

2009/10/16 torefj <torefj@gmail.com>

>
> You specify the failover protocol by enclosing the existing URL with
> "failover:(<existing_url>)"
>
> So you'll need to change the URL that you are connecting with to for
> example
> look like:
> failover:(tcp://localhost:1234)
>
> Beware though that if you are using activeMQ 5.2 or before the failover
> protocol does not have a timeout setting and any connecting threads will
> block until a connection is re-established.
>
> -Tore
>
>
> bbuzzard wrote:
> >
> > I'm a newbie to ActiveMQ and I need a little help.  I followed an example
> > (
> >
> http://www.codeproject.com/KB/docview/jms_to_jms_bridge_activem.aspx?display=Print
> >
> http://www.codeproject.com/KB/docview/jms_to_jms_bridge_activem.aspx?display=Print
> > ) showing how to set up a bridge between OpenJMS and ActiveMQ.  The
> bridge
> > seems to work perfectly until I stop then restart OpenJMS while leaving
> > ActiveMQ running.  Once I restart OpenJMS I try sending a message from it
> > to ActiveMQ, but ActiveMQ doesn't receive it until I stop and restart
> > ActiveMQ.  I can recreate the exact same problem by starting ActiveMQ
> > first and then OpenJMS.  I don't understand how or why ActiveMQ doesn't
> > try to reconnect.  Would someone please explain to me what should happen/
> >
> > After a little more reading it looks like failover should fix this
> > problem, but I don't know how to configure it.  I'm attaching the config
> > file that I use for ActiveMQ bridging.  Would someone please show me the
> > correct way to configure failover?
> >
> >  http://www.nabble.com/file/p25909047/bridge-activemq.xml
> > bridge-activemq.xml
> >
>
> --
> View this message in context:
> http://www.nabble.com/How-to-configure-failover-for-jmsBridgeConnector-tp25909047p25918800.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 
http://blog.garytully.com

Open Source Integration
http://fusesource.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message