activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: Many TCP consumer threads are being started up but no messages getting to queue
Date Mon, 12 Oct 2009 11:07:41 GMT
possibly add the following to your log4j configuration:

## Be sure that ActiveMQ messages are not logged to 'jms' appender
log4j.logger.org.apache.activemq=INFO, stdout


see:
http://activemq.apache.org/how-do-i-use-log4j-jms-appender-with-activemq.html

2009/10/10 Mike Nooney <noonim1@gmail.com>

>
> Hi,
>
> I am using the Log4j JMSQueueAppender to log to a JMS Queue provided by an
> ActiveMQ Broker (ActiveMQ V5.2).
>
> The logs show that many TCP consumer threads are being started up at the
> same time. Also no messages are appearing in the queue.
>
> Would anyone know if this is a configuration issue or something else?
>
> Active MQ configuration here:
> http://www.nabble.com/file/p25830809/activemq.conf.TXT activemq.conf.TXT
>
> Thanks,
> Mike
>
> HOSTNAME - 2009-10-10 16:06:20,229 [Thread-8] DEBUG
> org.apache.activemq.transport.WireFormatNegotiator - Sending:
> WireFormatInfo
> { version=3, properties={TightEncodingEnabled=true, CacheSize=1024,
> TcpNoDelayEnabled=true, SizePrefixDisabled=false, StackTraceEnabled=true,
> MaxInactivityDurationInitalDelay=10000, MaxInactivityDuration=30000,
> CacheEnabled=true}, magic=[A,c,t,i,v,e,M,Q]}
>
> The above statement appears once.
>
> HOSTNAME - 2009-10-10 16:06:20,245 [ActiveMQ Transport:
> tcp://localhost/127.0.0.1:61616] DEBUG
> org.apache.activemq.transport.tcp.TcpTransport - TCP consumer thread for
> tcp://localhost/127.0.0.1:61616 starting
>
> The above log statement appears hundreds of times when the webapp loads in
> the Tomcat server and starts logging.
>
> Log4j configuration
> ##############################JMS appender
> config###############################
> # define appender for JMS logger
> log4j.appender.jms=JMSQueueAppender
>
> log4j.appender.jms.InitialContextFactory=org.apache.activemq.jndi.ActiveMQInitialContextFactory
> log4j.appender.jms.ProviderUrl=tcp://localhost:61616
> log4j.appender.jms.QueueBindingName=logqueue
> log4j.appender.jms.QueueConnectionFactoryBindingName=ConnectionFactory
> log4j.appender.jms.FailsafeLoggerName=jmsFSlogger
> log4j.appender.jms.AttemptsTillRetry=50000
> # Set TimeToLive for messages on the queue -1 means no expiry
> log4j.appender.jms.TimeToLive=-1
>
> ################################################################################
> --
> View this message in context:
> http://www.nabble.com/Many-TCP-consumer-threads-are-being-started-up-but-no-messages-getting-to-queue-tp25830809p25830809.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 
http://blog.garytully.com

Open Source Integration
http://fusesource.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message