activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Stomp messages arriving without a message id
Date Tue, 13 Oct 2009 07:30:20 GMT
Hi Pete,

we didn't see this kind of problem before. Can you create a test case that
can reproduce the problem (ideally in Java
http://activemq.apache.org/stomp.html#Stomp-JavaAPI, but Ruby will work too)
and file a Jira request?

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Mon, Oct 12, 2009 at 10:10 PM, Pete Hodgson <nabble@thepete.net> wrote:

>
> Hi List,
>
> I'm using standard ruby stomp client to communicate with activeMQ 5.2.0,
> using non-persistent messages. Very rarely (maybe once every 10,000
> messages) the stomp client receives a message from the server with no
> message-id header. It does have other headers, but is missing the
> message-id. To make things worse, I'm using client ack. Because the client
> has no way to ack a message with no id its subscription becomes useless,
> and
> I have to restart my process.
>
> Does anyone have any insight on this? Is this a known issue with the stomp
> adapter? I'm assuming it's a server-side issue rather than client-side, but
> without sniffing traffic in my production environment (which would be very
> tricky) I'm not sure how I could find out more.
>
> Any suggestions gratefully received!
>
> Cheers,
> Pete
> --
> View this message in context:
> http://www.nabble.com/Stomp-messages-arriving-without-a-message-id-tp25862375p25862375.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message