activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eagle2009 <jsw...@163.com>
Subject Re: Creating a durable subscription on a topic, but the published messages were delivered several times some time when reconnecting.
Date Thu, 29 Oct 2009 08:06:25 GMT



Eagle2009 wrote:
> 
> Dear all,
> 
> I'm working on the durable subscription feature and find the following
> behavior unexpected:
> firstly, with the durable subscription program running, I send M1, M2 to
> the topic, it worked fine.
> next, I kill the durable subscription program, and send message M3, M4, M5
> to the topic.
> finally, I restart the durable subscription program, unexpected the
> program received M1, M2, M3, M4, M5 again.
> 
> Can anybody help on identify the issue? I created the durable subscription
> following up JMS specification and the session is no transaction and
> AUTO_ACKNOWLEDGE.
> 

Here comes some detailed deployment information:
I created a cluster with 4 brokers: HQ, B, C, D.
The durable subscriptions is created on Broker B, C and D to listen on a
topic. The published messages is generated on Broker HQ and sent to the
topic.
-- 
View this message in context: http://www.nabble.com/Creating-a-durable-subscription-on-a-topic%2C-but-the-published-messages-were-delivered-several-times-some-time-when-reconnecting.-tp26108226p26108426.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message