activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nmittal <nmit...@rblt.com>
Subject Re: CMS: problems installing 3.0.1
Date Wed, 28 Oct 2009 18:37:18 GMT

duh.. that was a typo.. thanks a lot Tim.


Timothy Bish wrote:
> 
> On Wed, 2009-10-28 at 11:18 -0700, nmittal wrote:
>> Hi,
>> I am trying to install CPP version 3.0.1 after download and untaring... I
>> do
>> 
>> # ./configure --with-apr=/usr/local/apr/bin/apr-1-config
>> --with-apr-util=/usr/local/apr/bin/apr-1-config
>> # make
> 
> Try
> 
> ./configure --with-apr=/usr/local/apr/bin/apr-1-config
> --with-apr-util=/usr/local/apr/bin/apu-1-config
> 
> or wherever apu-1-config happens to be, you are giving the APR config
> twice.
> 
> Regards
> Tim.
> 
> 
>> 
>> however it fails with the following error...
>> 
>> libtool: link: g++ -ansi -pedantic -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE
>> -I/usr/local/apr/include/apr-1 -I/usr/local/apr/include/apr-1 -W -Wall
>> -fPIC
>> -fstrict-aliasing -Wstrict-aliasing=2 -Wno-long-long -DLINUX=2
>> -D_REENTRANT
>> -D_GNU_SOURCE -I/usr/local/apr/include/apr-1
>> -I/usr/local/apr/include/apr-1
>> -Wno-non-virtual-dtor -Wno-unused-parameter -Wno-uninitialized
>> -I./../main
>> -g -O2 -o .libs/example example-main.o  ../main/.libs/libactivemq-cpp.so
>> /usr/local/apr/lib/libapr-1.so -luuid -lrt -lcrypt -lpthread -ldl
>> -Wl,-rpath
>> -Wl,/usr/local/apr/lib
>> ../main/.libs/libactivemq-cpp.so: undefined reference to `apr_uuid_get'
>> ../main/.libs/libactivemq-cpp.so: undefined reference to `apr_md5'
>> ../main/.libs/libactivemq-cpp.so: undefined reference to `apr_uuid_parse'
>> ../main/.libs/libactivemq-cpp.so: undefined reference to
>> `apr_uuid_format'
>> collect2: ld returned 1 exit status
>> make[2]: *** [example] Error 1
>> make[2]: Leaving directory
>> `/root/activemq-cpp-library-3.0.1/src/examples'
>> make[1]: *** [all-recursive] Error 1
>> make[1]: Leaving directory `/root/activemq-cpp-library-3.0.1'
>> make: *** [all] Error 2
>> mdguru2:~/activemq-cpp-library-3.0.1# 
>> 
>> my LD_LIBRARY_PATH points to where the apr libs are installed.
>> 
>> please help.
>> 
>> thanks
>> Nishant
> -- 
> Tim Bish
> http://fusesource.com
> http://timbish.blogspot.com/
> 
> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/CMS%3A-problems-installing-3.0.1-tp26099556p26099859.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message