activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From forda <daniel.forb...@bredband.net>
Subject Re: Getting Error while trying to achieve the Master/Slave config
Date Tue, 20 Oct 2009 08:09:18 GMT

Thank you, i will try that instead.
Cheers
Daniel

Dejan Bosanac wrote:
> 
> Fir the shared master/slave setup you don't need to define any network
> connectors, but just simply point both brokers to the same database.
> 
> Cheers
> --
> Dejan Bosanac - http://twitter.com/dejanb
> 
> Open Source Integration - http://fusesource.com/
> ActiveMQ in Action - http://www.manning.com/snyder/
> Blog - http://www.nighttale.net
> 
> 
> On Tue, Oct 20, 2009 at 8:20 AM, forda <daniel.forberg@bredband.net>
> wrote:
> 
>>
>> I forgot to provide the logs.
>>
>> Host1
>> http://www.nabble.com/file/p25970251/activemq.txt activemq.txt
>> http://www.nabble.com/file/p25970251/wrapper.txt wrapper.txt
>>
>> Host2
>> http://www.nabble.com/file/p25970251/activemq.txt activemq.txt
>> http://www.nabble.com/file/p25970251/wrapper.log wrapper.log
>>
>>
>> Daniel
>>
>>
>> forda wrote:
>> >
>> > Hello !
>> >
>> > Currently i am working for a customer to setup a ActiveMQ production
>> alike
>> > environment,
>> > designed for failover on the client or the server. Our first approach
>> is
>> > to use failover on
>> > the client and using a shared database building a Master/Slave scenario
>> > having a database
>> > cluster. It works in way that is described and in another not, getting
>> > errors. I have carefully
>> > consulted various documentation on the internet, fusesource and the
>> > ActiveMQ in action book.
>> > These documentation are good, but sometimes a link is missing.
>> >
>> > In this case i tested out the
>> > Master/Slave approach first with static discovery and the failover
>> > property set to true. In 5.20
>> > version of ActiveMQ the log says the failover property does not exist
>> > error in BeanCreation for
>> > DiscoveryNetworkConnector, had a look in the reference for Java and XML
>> > and couldn'nt so i
>> > skipped it. Though it seem to work while the first broker gets the lock
>> > and act as a master and
>> > the slaves waiting for acquire the lock. Then one of the brokers
>> shutdown
>> > one of the slaves took over.
>> >
>> > But when i looked in the logfiles i found som Error logs: connection
>> > refused to unknown. It doesent
>> > seem to be normal. Or ? I will attach the logs with this thread.
>> >
>> > Second i tried to use the multicast discovery isntead of using default
>> i
>> > wanted to define
>> > another name for the group, but unknown host exception. How do i manage
>> to
>> > define another
>> > name than default to delimit the acess to group on the network? With
>> > default it's work.
>> >
>> > Am i missing something here to get the whole thing working. I am
>> gratful
>> > for all advices.
>> > Thanks in advance.
>> >
>> > Regards,
>> >
>> > Daniel
>> >
>>
>> --
>> View this message in context:
>> http://www.nabble.com/Getting-Error-while-trying-to-achieve-the-Master-Slave-config-tp25960809p25970251.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> -----
> Dejan Bosanac
> 
> Open Source Integration - http://fusesource.com/
> ActiveMQ in Action - http://www.manning.com/snyder/
> Blog - http://www.nighttale.net
> 

-- 
View this message in context: http://www.nabble.com/Getting-Error-while-trying-to-achieve-the-Master-Slave-config-tp25960809p25971259.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message