activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From forda <daniel.forb...@bredband.net>
Subject Re: Error while connecting via JMX to a Broker located on RHEL 5
Date Fri, 16 Oct 2009 15:38:56 GMT

Hi Dejan !

I only get connection failed, so i assume that something is wrong with the
configuration on the server. But i could'nt find any, i tried many times. I
think
it's strange. Regarding telnet i am running the test on windows, i get the
same error using the jconsole creating a remote connection. 

In the startup
of ActiveMQ nothing strange is written to the log. The first that came up
was maybe there is some security restriction cause not using any credentials
to connect. With the SUN JMX connector this is possible to the set the
autenticate=false as in the attached wrapper.conf. I will attach the
Broker config just in case and the wrapper.log, activemq.log.

http://www.nabble.com/file/p25927475/activemq.log activemq.log 
http://www.nabble.com/file/p25927475/wrapper.log wrapper.log 
http://www.nabble.com/file/p25927475/activemq.xml activemq.xml 

Thanks in advance

Daniel



Dejan Bosanac wrote:
> 
> Hi Daniel,
> 
> what exception are you getting? Can you telnet to 1099 port on your host?
> 
> Cheers
> --
> Dejan Bosanac - http://twitter.com/dejanb
> 
> Open Source Integration - http://fusesource.com/
> ActiveMQ in Action - http://www.manning.com/snyder/
> Blog - http://www.nighttale.net
> 
> 
> On Fri, Oct 16, 2009 at 5:05 PM, forda <daniel.forberg@bredband.net>
> wrote:
> 
>>
>> Hi !
>>
>> From a UnitTest accessing a Broker via Spring and a BrokerviewBean in
>> order
>> to manage
>> the setup and cleanup functions. For that BrokerviewBean is used. It
>> works
>> fine at localhost
>> as well as connecting a remote Broker in a windows network, but while
>> trying
>> to the same thing
>> in Linux network a connection refused is issued.
>>
>> On the Linux box(RedHat), the Broker is started through the Java Service
>> Wrapper, and the jmx rows are enabled at a specific port, and the
>> property
>> useJmx=true is default because the ActiveMQ 5.2 version is used. The
>> wrapper.conf will be attached to this message.
>>
>> It is important to make this work because i design
>> a solution for a reminderagent sending SMS to unemployed remind them of
>> meetings with Job coaches. Using the DestinationViewBean to ask for the
>> Queuesize on a specific Queue in this case a send SMS queue which be used
>> by
>> a consumer/Messagelistener, if the this Queue is empty another listener
>> starts to consume messages in another queue used for resending SMS
>> message
>> a
>> number of times or until delivered. So i need to get this work on Linux
>> too,
>> it works perfectly fine on wnidows. I think this a smoth solution. I do
>> know
>> that the QueBrowser class also can be used but this is not the best
>> solution
>> i think.
>>
>> And for failover reason i assume that the jmx.uris can be used like this
>> setting a property on the client like this jmx.url=uri1,uri2...uriN or ?
>> Do
>> i need to use the failover protocol like for the connecting to the
>> broker. And is there a way to configure the DestinationViewBean so that
>> it
>> uses the actual master Broker.
>> Or how do i do this ?
>>
>> Any better solutions ? Thanks in advance
>>
>> Regards
>> Daniel
>>
>> http://www.nabble.com/file/p25926940/wrapper.conf wrapper.conf
>>
>>
>> --
>> View this message in context:
>> http://www.nabble.com/Error-while-connecting-via-JMX-to-a-Broker-located-on-RHEL-5-tp25926940p25926940.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> -----
> Dejan Bosanac
> 
> Open Source Integration - http://fusesource.com/
> ActiveMQ in Action - http://www.manning.com/snyder/
> Blog - http://www.nighttale.net
> 

-- 
View this message in context: http://www.nabble.com/Error-while-connecting-via-JMX-to-a-Broker-located-on-RHEL-5-tp25926940p25927475.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message