activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From torefj <tor...@gmail.com>
Subject Re: How to configure failover for jmsBridgeConnector
Date Fri, 16 Oct 2009 02:06:07 GMT

You specify the failover protocol by enclosing the existing URL with
"failover:(<existing_url>)"

So you'll need to change the URL that you are connecting with to for example
look like:
failover:(tcp://localhost:1234)

Beware though that if you are using activeMQ 5.2 or before the failover
protocol does not have a timeout setting and any connecting threads will
block until a connection is re-established.

-Tore


bbuzzard wrote:
> 
> I'm a newbie to ActiveMQ and I need a little help.  I followed an example
> (
> http://www.codeproject.com/KB/docview/jms_to_jms_bridge_activem.aspx?display=Print
> http://www.codeproject.com/KB/docview/jms_to_jms_bridge_activem.aspx?display=Print
> ) showing how to set up a bridge between OpenJMS and ActiveMQ.  The bridge
> seems to work perfectly until I stop then restart OpenJMS while leaving
> ActiveMQ running.  Once I restart OpenJMS I try sending a message from it
> to ActiveMQ, but ActiveMQ doesn't receive it until I stop and restart
> ActiveMQ.  I can recreate the exact same problem by starting ActiveMQ
> first and then OpenJMS.  I don't understand how or why ActiveMQ doesn't
> try to reconnect.  Would someone please explain to me what should happen/
> 
> After a little more reading it looks like failover should fix this
> problem, but I don't know how to configure it.  I'm attaching the config
> file that I use for ActiveMQ bridging.  Would someone please show me the
> correct way to configure failover?
> 
>  http://www.nabble.com/file/p25909047/bridge-activemq.xml
> bridge-activemq.xml 
> 

-- 
View this message in context: http://www.nabble.com/How-to-configure-failover-for-jmsBridgeConnector-tp25909047p25918800.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message