activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: CMS 3.0.1: Get exception after sometime (approx 10secs)
Date Fri, 30 Oct 2009 18:14:14 GMT
On Fri, 2009-10-30 at 10:00 -0700, nmittal wrote:
> I ported my code from CPP 2.2.5 to CPP 3.0.1 and after a successful build
> tried to run it. I can see the Queues and Topics created by the code but
> after some 10 secs or so.. i get the following messages...
> 
> Exception: DataInputStream::readLong - Reached EOF
>         FILE: ./decaf/io/DataInputStream.h, LINE: 378
>         FILE: decaf/io/DataInputStream.cpp, LINE: 162
>         FILE: activemq/wireformat/openwire/OpenWireFormat.cpp, LINE: 275
>         FILE: activemq/transport/IOTransport.cpp, LINE: 235
> 
> Exception: DataInputStream::readLong - Reached EOF
>         FILE: ./decaf/io/DataInputStream.h, LINE: 378
>         FILE: decaf/io/DataInputStream.cpp, LINE: 162
>         FILE: activemq/wireformat/openwire/OpenWireFormat.cpp, LINE: 275
>         FILE: activemq/transport/IOTransport.cpp, LINE: 235
> 
> Exception: DataInputStream::readLong - Reached EOF
>         FILE: ./decaf/io/DataInputStream.h, LINE: 378
>         FILE: decaf/io/DataInputStream.cpp, LINE: 162
>         FILE: activemq/wireformat/openwire/OpenWireFormat.cpp, LINE: 275
>         FILE: activemq/transport/IOTransport.cpp, LINE: 235
> 
> 
> Please note that this happens even when there are no messages sent or
> received. This same code worked fine with CMS 2.2.5
> 
> thanks
> Nishant

What version of the broker are you using?  If its 5.3.0 you can try
adding wireFormat.MaxInactivityDuration=-1 to you connection URI and see
if that resolves the issue.


-- 
Tim Bish
http://fusesource.com
http://timbish.blogspot.com/




Mime
View raw message