activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Installing Activemq-cpp in HP-UX
Date Wed, 28 Oct 2009 14:10:11 GMT
On Mon, 2009-10-26 at 22:37 -0700, Radha Manickam wrote:
> Hi Tim,
> 
> I have attached the config.log.
> 
> Radha.

>>From what I've read about the HP UX pthreads impl it sounds as if
there's some problems with the way they've defined the pthread_create
which break autoconfs tests.  You could modify this portion of the
configure.ac to remove the AC_CHECK_LIB and just set the LIBS with the
libraries that you need on HP UX to compile, not sure any change is
necessary.  Once done just run ./autogen.sh and you should have a
working configure script.

  *) ## Unix configuration

    AC_CHECK_LIB(pthread, pthread_create,[have_pthread="yes"],
                AC_MSG_ERROR([libpthread not found!]))

    PLAT_CXXFLAGS="-ansi -pedantic"
    PLAT_LIBS="-lm -lpthread -luuid"

Regards
Tim.

> 
> 
> Timothy Bish wrote:
> > 
> > On Thu, 2009-10-22 at 22:22 -0700, Radha Manickam wrote:
> >> Hi, 
> >> 
> >> I am using Actimemq-cpp version 3.0.
> >> Autoconf ==> 2.64
> >> Automake ==> 1.11
> >> libtool ==> 2.2.6
> >> gcc ==> 4.2.3
> >> 
> >> I have installed all the dependencies.
> >> I am able to install Apr and apr-util without any error.
> >> But not able to compile activemq-cpp.
> >> 
> >> Thanks.
> >> Radha.
> > 
> > I'd need to take a look at your config.log file to see if there's any
> > indication in there about what is causing the error.  You are welcome to
> > open a new Jira issue and attach a the log.
> > 
> > Regards
> > Tim.
> > 
> > 
> > -- 
> > Tim Bish
> > http://fusesource.com
> > http://timbish.blogspot.com/
> > 
> > 
> > 
> > 
> > 
> http://www.nabble.com/file/p26072354/config.log config.log 
-- 
Tim Bish
http://fusesource.com
http://timbish.blogspot.com/




Mime
View raw message