activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: Messages left on the queue when using a transacted session.
Date Tue, 15 Sep 2009 07:40:53 GMT

On 15 Sep 2009, at 07:33, Robert Nicholson wrote:

> On each occasion when I notice messages are no longer being  
> delivered. If I restart my app after restarting the broker the  
> messages begin to deliver.
>
> On Sep 15, 2009, at 12:56 AM, Rob Davies wrote:
>
>>
>> On 15 Sep 2009, at 06:42, Robert Nicholson wrote:
>>
>>> So, I have a pretty standard JMS message listener but when using  
>>> ActiveMQ it often just doesn't receive any messages even when  
>>> there are messages on the queue. The Session is a transacted one  
>>> with AUTO_ACKNOWLEDGE but for some reason the messages are never  
>>> taken off the queue.
>>>
>>> I believe AUTO_ACKNOWLEDGE is ignored and eventually it says  
>>> SESSION_TRANSACTED but what I don't understand is upon committing  
>>> the session the messages are still on the queue.
>>>
>>> Why is that?
>>>
>>>
>>>
>>
>>
>> Er - not sure - can you share your code  - or provide a test case ?
>>
>> cheers,
>>
>> Rob
>>
>> Rob Davies
>> http://twitter.com/rajdavies
>> I work here: http://fusesource.com
>> My Blog: http://rajdavies.blogspot.com/
>> I'm writing this: http://www.manning.com/snyder/
>>
>>
>>
>>
>>
>


Have you tried the 5.3-SNAPSHOT ?

thanks,

Rob

Rob Davies
http://twitter.com/rajdavies
I work here: http://fusesource.com
My Blog: http://rajdavies.blogspot.com/
I'm writing this: http://www.manning.com/snyder/






Mime
View raw message