activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: ActiveMQ creates lots of processes and then hangs
Date Thu, 24 Sep 2009 10:07:59 GMT
It would be worth trying with 5.3-SNAPSHOT - and seeing if you get the  
same - also change your database to use the kahaDB persistenceAdapter
On 24 Sep 2009, at 08:56, minz wrote:

>
> ActiveMQ 5.1 runs standalone
> Windows Server 2003 SP1
> Web app runs in Tomcat 6.0.18
>
> http://www.nabble.com/file/p25540571/activemq.xml activemq.xml
>
> We have one producer thread that sends to queue 'DataQueue', no  
> consumer
> running at that time. After about 4000 messages, ActiveMQ hangs.
>
> If a consumer runs, and we stop the producer in time, we can restart  
> the
> producer
> after all messages are consumed. If we don't stop the produces, the  
> same
> problems
> occurs as described above.
>
> When ActiveMQ hangs, netstat lists hundreds of processes with  
> process id 0
> at
> port 61616 in wait state ("WARTEND"):
>
> TCP    127.0.0.1:4332         127.0.0.1:61616        WARTEND         0
> TCP    127.0.0.1:4333         127.0.0.1:61616        WARTEND         0
>
> and so on.
>
> Also, Tomcat hangs when this occurs. Apparently, this is to do with  
> so many
> ports
> being used?
>
> After restart, the ActiveMQ web console lists a possibly random  
> number of
> sent, but
> undelivered messages in queue 'DataQueue'.
>
> Any help would be greatly appreciated.
>
> Minz
>
> -- 
> View this message in context: http://www.nabble.com/ActiveMQ-creates-lots-of-processes-and-then-hangs-tp25540571p25540571.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Rob Davies
http://twitter.com/rajdavies
I work here: http://fusesource.com
My Blog: http://rajdavies.blogspot.com/
I'm writing this: http://www.manning.com/snyder/






Mime
View raw message