activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Tran <dant...@gmail.com>
Subject undesirable activemq-data directory
Date Mon, 28 Sep 2009 04:51:19 GMT


My ActiveMQ configuration does not persist message, all messages in in
memory. However activemq-data directory is created uppon startup.  is this a
bug?

i tested with both 5.2. and 5.3-SNAPSHOT.

Here is my configuration

  <!--  lets create an embedded ActiveMQ Broker -->
  <amq:broker useJmx="true" persistent="false">

    <!-- Destination specific policies using destination names or wildcards
-->

    <amq:destinationPolicy>
      <amq:policyMap>
        <amq:policyEntries>
          <amq:policyEntry topic=">"  producerFlowControl="true"
memoryLimit="10 mb" />
        </amq:policyEntries>
      </amq:policyMap>
    </amq:destinationPolicy>

    .....

    <!--  The maximum about of space the broker will use before slowing down
producers -->
    <amq:systemUsage>
      <amq:systemUsage>
        <amq:memoryUsage>
          <amq:memoryUsage limit="200 mb" />
        </amq:memoryUsage>
        <!-- 
        <amq:storeUsage>
          <amq:storeUsage limit="1 gb" name="foo" />
        </amq:storeUsage>
        <amq:tempUsage>
          <amq:tempUsage limit="20 mb" />
        </amq:tempUsage>
        -->
      </amq:systemUsage>
    </amq:systemUsage>
    
    <amq:transportConnectors>
      <amq:transportConnector
uri="${fdb.broker.protocol}://0.0.0.0:${fdb.broker.port}" />
    </amq:transportConnectors>


  </amq:broker>



-- 
View this message in context: http://www.nabble.com/undesirable-activemq-data-directory-tp25640617p25640617.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message