activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From richrem <r...@remingtons.us>
Subject issues with connection start timeout
Date Fri, 25 Sep 2009 14:34:42 GMT

I have read the docs on the failover and the tcp transport.  I understand I
can set various properties on the broker URL.  What I'm trying to do is
build a very simple monitor that runs periodically to check that ActiveMQ is
still alive and if not, send a notification that someone needs to start (or
reboot) AMQ.  Currently, I have tried the following values for broker URL:

1) tcp://localhost:61616?wireFormat.maxInactivityDuration=0

When using this, the monitor thread blocks in the connection.start() call

2)
tcp://localhost:61616?wireFormat.maxInactivityDuration=0&maxReconnectAttempts=1

I tried this, thinking that failover was somehow coming into play, but the
ActiveMQConnectionFactory complained about an invalid property
{maxReconnectAttempts=1}

3) tcp://localhost:61616?wireFormat.maxInactivityDuration=0&soTimeout=2000

I get the same behavior as the first option - e.g. the soTimeout does not
seem to work as I hoped, which is to throw an exception if I can't start the
connection within a small amount of time.

It seems that failover is in play somehow, but I don't know how to switch it
off.  Any advice is welcome.

Thanks,
Rich
-- 
View this message in context: http://www.nabble.com/issues-with-connection-start-timeout-tp25613213p25613213.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message