activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Gill <>
Subject Re: Comet Style AJAX Servlet Problems
Date Fri, 11 Sep 2009 21:24:25 GMT
Hi Dejan,

I started creating a jira issue but there's no place to attach a file
- here is a simple case to demonstrate, consisting of an html page
with JS that subscribes to a random queue, the _amq js file, and

Refreshing the page (and therefore subscribing to a new random queue)
does not seem to work in firefox, but does work in safari.  any ideas
why that is?

To run the demo, unzip the attached zip file into the /demo directory
of the activemq project, and then hit http://localhost:8161/demo/bug/
in firefox/safari - add things to the queue from the activemq admin

I'd be happy to continue creating the jira issue if you suggest a
place to upload the file that i can link from the jira issue.


On Fri, Sep 11, 2009 at 9:51 AM, Dejan Bosanac <> wrote:
> Hi Chris,
> can you raise a Jira for this, ideally with a JS script thta can reproduce
> the problem?
> Cheers
> --
> Dejan Bosanac
> Open Source Integration -
> ActiveMQ in Action -
> Blog -
> On Wed, Sep 9, 2009 at 11:42 PM, Christopher Gill <>wrote:
>> Hi all,
>> We're trying to use the Jetty continuations MessageListenerService as
>> an endpoint for an AJAX app where people get near-realtime updates in
>> their browser, where each end user subscribes to their own queue of
>> notifications.  (If the user were to leave and then come back, they'd
>> get another, brand new queue (with a new, unique name - not sure if
>> this is relevant.)
>> The plumbing seems to be working pretty well and it's quite a flashy
>> bit of work, but we're seeing strange behavior with the very first
>> message placed on the queue just disappearing (the
>> MessageListenerServlet shows it consumes them but they never come down
>> the pipe to the browser over HTTP - or maybe they're being sent to a
>> different client or something?).  Sometimes none of the subsequent
>> messages ever show up on the client, other times everything works as
>> expected.
>> We tried unsuccessfully to figure out the cause of the problem,
>> because it's sporadic, but it seems to be at least somewhat related to
>> http sessions (a cleanly wiped firefox will work great - but then
>> repeating the test in the same firefox usually doesn't work) and for
>> whatever reason safari seems to work OK whether its cache has been
>> cleared or not.  Since there's a difference between web browsers the
>> obvious implication is that something is messed up client-side but
>> we're having a real hard time figuring out what that could be - no JS
>> exceptions or errors, etc, so we've tried messing with all kinds of
>> caching to no avail.  This is activemq 5.2.0.  I attached two files,
>> one is the debug output from a working session (with safari) and one
>> from a non-working session with firefox - the events seem to all show
>> up in the logs OK, but for whatever reason they don't make it to the
>> browser.
>> Does anything jump out at you?  Anything else I can try?  I've run out
>> of ideas.  The current thinking is that something is getting muddled
>> with the mapping of users/sessions to subscriptions, maybe?  Any
>> ideas?
>> Thanks,
>> Chris

View raw message