activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Gill <gillt...@gmail.com>
Subject Comet Style AJAX Servlet Problems
Date Wed, 09 Sep 2009 21:42:25 GMT
Hi all,

We're trying to use the Jetty continuations MessageListenerService as
an endpoint for an AJAX app where people get near-realtime updates in
their browser, where each end user subscribes to their own queue of
notifications.  (If the user were to leave and then come back, they'd
get another, brand new queue (with a new, unique name - not sure if
this is relevant.)

The plumbing seems to be working pretty well and it's quite a flashy
bit of work, but we're seeing strange behavior with the very first
message placed on the queue just disappearing (the
MessageListenerServlet shows it consumes them but they never come down
the pipe to the browser over HTTP - or maybe they're being sent to a
different client or something?).  Sometimes none of the subsequent
messages ever show up on the client, other times everything works as
expected.

We tried unsuccessfully to figure out the cause of the problem,
because it's sporadic, but it seems to be at least somewhat related to
http sessions (a cleanly wiped firefox will work great - but then
repeating the test in the same firefox usually doesn't work) and for
whatever reason safari seems to work OK whether its cache has been
cleared or not.  Since there's a difference between web browsers the
obvious implication is that something is messed up client-side but
we're having a real hard time figuring out what that could be - no JS
exceptions or errors, etc, so we've tried messing with all kinds of
caching to no avail.  This is activemq 5.2.0.  I attached two files,
one is the debug output from a working session (with safari) and one
from a non-working session with firefox - the events seem to all show
up in the logs OK, but for whatever reason they don't make it to the
browser.

Does anything jump out at you?  Anything else I can try?  I've run out
of ideas.  The current thinking is that something is getting muddled
with the mapping of users/sessions to subscriptions, maybe?  Any
ideas?

Thanks,
Chris

Mime
View raw message