activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BillCCHKK <wpw...@gmail.com>
Subject Re: Problem setting the ActiveMQ logging level
Date Mon, 24 Aug 2009 18:08:43 GMT



BillCCHKK wrote:
> 
> Hi,
> 
> I am running ActiveMQ 5.2, embedded within another Java application,
> running on Java 6.  I am not using log4j, nor do I have log4j.jar in my
> classpath.  According to
> http://activemq.apache.org/how-can-i-enable-detailed-logging.html, if I am
> not using log4j, I will get the Apache Commons Logging SimpleLog.
> 
> So, I follow the SimpleLog documentation, and set the log level to "warn"
> using:
> 
> 		System.setProperty("org.apache.commons.logging.simplelog.defaultlog",
> "warn");
> 
> But I'm still getting "info" level messages sent to stderr.
> 
> Can anyone tell me what I'm doing wrong?  Is there any way to tell what
> actual logging implementation commons logging is giving me?
> 
> Thanks,
> - Bill
> 
> 

OK, the only way I could get this to work was to explicitly set the
commons-logging log implementation before I started the embedded ActiveMQ. 
i.e.:

		System.setProperty("org.apache.commons.logging.Log", 
				"org.apache.commons.logging.impl.SimpleLog");
		System.setProperty("org.apache.commons.logging.simplelog.defaultlog", 
				activemq_log_level);

Any other suggestions?

Thanks,
- Bill


-- 
View this message in context: http://www.nabble.com/Problem-setting-the-ActiveMQ-logging-level-tp25120033p25120893.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message