activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lyall <Ly...@The-Pearces.com>
Subject Re: ActiveMQ Brokers using HTTP to communicate
Date Fri, 21 Aug 2009 01:01:53 GMT

Excellent.
I have the two brokers talking using http using the configuration settings,
shown below.
I have disabled multicast as I only want the two to communicate using port
80.
Thank you.

        <transportConnectors>
            <transportConnector name="openwire" uri="tcp://localhost:61616"
/>
           <!--  <transportConnector name="openwire"
uri="tcp://localhost:61616" discoveryUri="multicast://default"/> -->
            <transportConnector name="http" uri="http://0.0.0.0:80"/>
            <transportConnector name="ssl" uri="ssl://localhost:61617"/>
            <transportConnector name="stomp" uri="stomp://localhost:61613"/>
            <transportConnector name="xmpp" uri="xmpp://localhost:61222"/>
        </transportConnectors>

        <networkConnectors>
            <!-- by default just auto discover the other brokers -->
            <!-- !! <networkConnector name="default-nc"
uri="multicast://default"/> -->
            <!-- Example of a static configuration: -->
            <networkConnector name="Host1 and Host2" 
			       uri="static://(http://192.168.1.1:80,http://192.168.1.2:80)"/>
        </networkConnectors>



-- 
View this message in context: http://www.nabble.com/ActiveMQ-Brokers-using-HTTP-to-communicate-tp25054814p25072666.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message