activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "psharma8@sapient.com" <pshar...@sapient.com>
Subject Re: TTL set to 30 seconds, but messages are not getting expired.
Date Wed, 19 Aug 2009 13:05:31 GMT

Thanks for replying. I tried with this line of code. but still messages are
not getting expired.

TimeSpan timeSpan = new TimeSpan(0, 0, 30);
this.producer.Send(bytesMessage, true, 1, timeSpan);


psharma8@sapient.com wrote:
> 
> I tried to test for TTL. But it is not working fine.
> I check messages @ "http://localhost:8161/admin". Messages are not getting
> expired after specified time.
> 
>         public void SendMessage(IBusMessage busMessage)
>         {
>             if (!this.isDisposed)
>             {
>                 IBytesMessage bytesMessage =
> this.session.CreateBytesMessage();
>                 byte[] byteArray =
> HelperUtils.GetByteArrayWithObject(busMessage.GetSerializableMessage());
>                 bytesMessage.Content = byteArray;
>              bytesMessage.NMSTimeToLive = new TimeSpan(0, 0, 30);
>              bytesMessage.NMSPersistent = true;
>                 this.producer.Send(bytesMessage);
>             }
> 	  }
> 
> Please let me know if there is any other changes to be made.
> 

-- 
View this message in context: http://www.nabble.com/TTL-set-to-30-seconds%2C-but-messages-are-not-getting-expired.-tp25041966p25043705.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message