activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From greenbean <Kevin.Urci...@ngc.com>
Subject DLQ Not Working In ActiveMQ After Upgrade From 4 To 5
Date Wed, 12 Aug 2009 18:19:05 GMT

I recently switched from ActiveMQ 4 to 5.  I have been having issues getting
messages to go to a DLQ after rollbacks.

http://www.nabble.com/file/p24942054/out2.txt out2.txt 

Attached is a log showing a message consumer doing a rollback several times. 
The message is rolled back and redelivered at first.  However, after a few
times the message appears to rollback, but is not redelivered, nor do I see
it in a DLQ.

Can you provide assistance on tracking down what is happening?

I have the following in my ActiveMQ xml file:

<amq:destinationPolicy>


			<amq:policyMap>
				<amq:policyEntries>
				    <amq:policyEntry queue="*">
				        <amq:deadLetterStrategy>
                            <amq:individualDeadLetterStrategy
queuePrefix="DLQ." useQueueForQueueMessages="true" />
                        </amq:deadLetterStrategy>
				    </amq:policyEntry>				
				
					<amq:policyEntry queue="lanternRequestQueue">
						<property name="dispatchPolicy">
							<ref
								bean="comparedSubscriptionRoundRobinDispatchPolicy" />
						</property>
					</amq:policyEntry>
				</amq:policyEntries>
			</amq:policyMap>
		</amq:destinationPolicy>
-- 
View this message in context: http://www.nabble.com/DLQ-Not-Working-In-ActiveMQ-After-Upgrade-From-4-To-5-tp24942054p24942054.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message