activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alistair Young <alistair.yo...@uhi.ac.uk>
Subject Re: No IConnectionFactory implementation problem
Date Thu, 20 Aug 2009 07:14:05 GMT
thanks for that - they weren't in the path for the exe. Works now.

cheers,

Alistair


--  
mov eax,1
mov ebx,0
int 80h




On 19 Aug 2009, at 17:09, Timothy Bish wrote:

> On Wed, 2009-08-19 at 15:59 +0100, Alistair Young wrote:
>> Hi there,
>>
>> I've downloaded the NMS and ActiveMQ binary assemblies 1.1.0, as well
>> as building them from source but I keep getting this error:
>>
>> No IConnectionFactory implementation found for connection URI:
>> activemq:tcp://host.com:61613?transport.wireformat=stomp
>
> does the code work if you remove the stomp wireformat option?
> is the nmsprovider-activemq.config in a location that is visible to  
> the
> executing application?
>
>>
>> from this code:
>>
>> using Apache.NMS;
>> using Apache.NMS.ActiveMQ;
>> using Apache.NMS.ActiveMQ.Commands;
>> using Apache.NMS.ActiveMQ.Transport.Stomp;
>> Uri connectURI = new Uri("activemq:tcp://host.com:61613?
>> transport.wireformat=stomp");
>> IConnectionFactory factory = new NMSConnectionFactory(connectURI);
>>
>> is there anything else I need to include to get stomp/activemq  
>> support
>> working? I've used the ActiveMQCPP library and that needs initialized
>> to get rid of a similar error:
>>
>> ActiveMQCPP::initializeLibrary();
>>
>> is there a similar requirement for nms? There doesn't seem to be
>> anything in the examples.
>>
>> thanks,
>>
>> Alistair
>>
>>
>>
> -- 
> Tim Bish
> http://fusesource.com
> http://timbish.blogspot.com/
>
>
>


Mime
View raw message