activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: Stuck messages - Dispatch issues
Date Fri, 31 Jul 2009 07:35:33 GMT
can you share the details of the compilation issues so we can help diagnose?

2009/7/30 couzteau <couzteau@bitfaeule.net>

>
> Thanks for the info!
>
> I integrated 5.3-snapshot but ran into compile issues with the latest jar -
> So I abandoned that.
>
>
>
> Gary Tully wrote:
> >
> > in the absence of a test case, the best approach is to try out a
> > 5.3-SNAPSHOT
> >
> > 2009/7/30 couzteau <couzteau@bitfaeule.net>
> >
> >>
> >> Has this been solved yet? I'm seeing it with 5.2.0.
> >>
> >> I'm seeing an issue that occurs on some machines (where machines are
> >> identical regarding OS, Java version and hardware).
> >>
> >> Consumers that are on the same machine as the producer usually work
> fine.
> >>
> >> It's a major blocker for us - any comments highly appreciated.
> >>
> >>
> >> TIA  Jacques
> >>
> >>
> >>
> >>
> >> chrajanirao wrote:
> >> >
> >> > We are seeing issues with ActiveMQ 5.1 and 5.2 RC2 with message
> >> > dispatching from queues. It is easily reproducible even using the out
> >> of
> >> > the box activemq configuration.
> >> >
> >> > Send messages to the a queue (QueueA) using multiple threads (10 or 20
> >> > thread in a loop of 10) using JMeter or your custom code. Have the
> >> > consumer setup using spring DMLC (DefaultMessageListenerContainer) or
> >> with
> >> > regular JMS API sync or async consumption with multiple consumers.
> >> > Consumer part can be configured using Camel to consumer from QueueA
> and
> >> > put the messages in QueueB within ActiveMQ configuration as well.
> >> >
> >> > After receiving some messages (the number is different each time), the
> >> > consumers stop receiving any messages even though there are some left
> >> on
> >> > the queue. Basically, the broker don't dispatch the messages  and they
> >> are
> >> > stuck until restart of the broker. Any new messages sent to the queue
> >> > after this are sometimes dispatched and other times they are stuck
> too.
> >> >
> >> > This certainly seems like a major bug in the dispatch mechanism. I
> have
> >> > found below posts that state the exact problem.
> >> >
> >> >
> >>
> http://www.nabble.com/Pending-Messages-are-shown-in-ActiveMQ-td20241332.html
> >> >
> >> >
> >>
> http://www.nabble.com/Consumer-Listener-stop-receving-message-until-ActiveMQ-restart-td20355247.html
> >> >
> >> > This is a very basic use case and I wonder how the version 5.1 is
> >> > currently used in production, if anyone is using at all.
> >> >
> >> > We tried with prefetch limit as 1, asyncDispatch as true and false,
> >> > session transacted as true and false. In all cases, the dispatch
> >> problem
> >> > still exists starting after 100 messages until 1000 messages.
> >> >
> >> > I hope any of the active commiters looks into this issue seriously.
> >> Would
> >> > really appreciate the help.
> >> >
> >> > Thanks,
> >> > Rajani.
> >> >
> >>
> >> --
> >> View this message in context:
> >>
> http://www.nabble.com/Stuck-messages---Dispatch-issues-tp20467949p24733104.html
> >> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> >>
> >>
> >
> >
> > --
> > http://blog.garytully.com
> >
> > Open Source Integration
> > http://fusesource.com
> >
> >
>
> --
> View this message in context:
> http://www.nabble.com/Stuck-messages---Dispatch-issues-tp20467949p24744031.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 
http://blog.garytully.com

Open Source Integration
http://fusesource.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message