activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Messages Stuck in the queue(with the broker)
Date Wed, 22 Jul 2009 16:45:18 GMT
Hi,

do you use auto ack for the consumer as well?

It would be great if you could provide the source code that demonstrates the
problem.

Cheers
--
Dejan Bosanac

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Tue, Jul 21, 2009 at 5:12 PM, guptaviv <vivek.july2@gmail.com> wrote:

>
> Hi,
>
> We are having the messaging setup where we are using one Listener and one
> one producer.
> I am trying to repeatedly send the messages through the same producer.
> The problem is, very frequently the messages are stuck in the queue with
> the
> broker.
> The listener is absolutely free and but still the broker is not dispatching
> the messages to the Listener.
> Following is the configuration that we are using for producer:
> deliverymode : persistent
> ackMode: auto_acknowledge
>
> We are not setting any other configuration parameters(using default).
>
> The problem gets fixed after some time when you restart the broker or
> Listener but the issue reappears after some time again.
>
> Is there any solution/workaround to this issue. Please let me know if
> anyone
> has thoughts/advices on this.
>
> Thanks,
> Vivek
> --
> View this message in context:
> http://www.nabble.com/Messages-Stuck-in-the-queue%28with-the-broker%29-tp24589627p24589627.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message