activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "lord.breetai" <ia_to_the_st...@yahoo.es>
Subject javax.jms.InvalidClientIDException: No clientID specified for connection disconnect request
Date Tue, 28 Jul 2009 19:38:23 GMT

Hi 
Recently I configure ActiveMQ with jboss-4.0.2, apparenly all works fine;
however  when try sent jms messages from activeMQ queue to message driven
bean, saw in the log file the next warning

15:25:00,119 WARN  [Service] Failed to remove connection ConnectionInfo
{commandId = 1, responseRequired = true, co
nnectionId = ID:deltamachine-51095-1248809080501-2:5, clientId = null,
userName = defaultUser, password = defaultPassw
ord, brokerPath = null, brokerMasterConnector = false, manageable = true,
clientMaster = true}
javax.jms.InvalidClientIDException: No clientID specified for connection
disconnect request
        at
org.apache.activemq.broker.region.RegionBroker.removeConnection(RegionBroker.java:223)
        at
org.apache.activemq.broker.TransactionBroker.removeConnection(TransactionBroker.java:248)
        at
org.apache.activemq.broker.BrokerFilter.removeConnection(BrokerFilter.java:110)
        at
org.apache.activemq.advisory.AdvisoryBroker.removeConnection(AdvisoryBroker.java:214)
        at
org.apache.activemq.broker.BrokerFilter.removeConnection(BrokerFilter.java:110)
        at
org.apache.activemq.broker.MutableBrokerFilter.removeConnection(MutableBrokerFilter.java:117)
        at
org.apache.activemq.broker.TransportConnection.processRemoveConnection(TransportConnection.java:721)
        at org.apache.activemq.command.RemoveInfo.visit(RemoveInfo.java:60)
        at
org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:305)
        at
org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:179)
        at
org.apache.activemq.transport.ResponseCorrelator.onCommand(ResponseCorrelator.java:104)
        at
org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:68)
        at
org.apache.activemq.transport.vm.VMTransport.iterate(VMTransport.java:205)
        at
org.apache.activemq.thread.PooledTaskRunner.runTask(PooledTaskRunner.java:122)
        at
org.apache.activemq.thread.PooledTaskRunner$1.run(PooledTaskRunner.java:43)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)

The messages arrives correctly to mdb but I can not understand why the
warning in the log file.
I use ActiveMQ 5.0.2  and supposedly this problem was solved

see:

http://www.nabble.com/No-clientID-specified-for-connection-disconnect-request-td18008702.html#a18008702
http://www.nabble.com/No-clientID-specified-for-connection-disconnect-request-td18008702.html#a18008702


Thanks for your help

Atte
lord breetai
-- 
View this message in context: http://www.nabble.com/javax.jms.InvalidClientIDException%3A-No-clientID-specified-for-connection-disconnect-request-tp24706471p24706471.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message