activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From RakeshRay <Rakesh....@Proquest.com>
Subject Re: Multiple consumer in exclusive mode does not work.
Date Fri, 17 Jul 2009 13:53:37 GMT

Good to know that it could be fixed in 5.3.
Please help me understand the fix here...
Was the fix made to the broker? If yes then it should not matter what
protocol I use to get the messages out of the queue!
Am I making sense here?

Or if you can point me to  the full detail of the problem and the details
about the fix, that could help me understand better as well.

Thanks you for your time so far.


Gary Tully wrote:
> 
> Exclusive Consumers is designed to work that way.
> 
> If you have very high load and message spooling to disk you may be
> seeing some duplicate message delivery. Some issues around occasional
> duplicate delivery were addresses on trunk over the past few months.
> The current 5.3-SNAPSHOT should behave better in this regard with the
> caveat that Stomp was not a prerequisite for the behavior.
> If your test scenario does not work as expected with a 5.3-SNAPSHOT
> please raise a jira issue with a test case so we can attempt to
> address the issue for the 5.3 release.
> 
> 2009/7/15 RakeshRay <Rakesh.Ray@proquest.com>:
>>
>> Starting multiple consumer using Stomp protocol, in exclusive mode kills
>> others and just keeps one consumerr alive.
>> How do I get unique messages using multiple consumers?
>>
>> If I turn off exclusive mode, and run multiple consumers they seems to
>> get
>> the same message 1% off time.
>>
>> Any suggestions are welcomed!
>> Using active mq 5.2
>> --
>> View this message in context:
>> http://www.nabble.com/Multiple-consumer-in-exclusive-mode-does-not-work.-tp24506735p24506735.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> 
> -- 
> http://blog.garytully.com
> 
> Open Source Integration
> http://fusesource.com
> 
> 

-- 
View this message in context: http://www.nabble.com/Multiple-consumer-in-exclusive-mode-does-not-work.-tp24506735p24534850.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message