activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From RakeshRay <Rakesh....@Proquest.com>
Subject Re: Queue does not drain completely.
Date Fri, 10 Jul 2009 12:56:19 GMT

Thanks for the suggestions, I tried, but does not help.
It could be the problem with the Stomp protocol!.
Anyone using Stomp to Connect to use Active MQ?


mjustin wrote:
> 
> If it depends on message number / message size, maybe the broker needs
> more buffer space, you can try increasing the memoryLimit in the
> activemq.xml file. It helped with a similar problem where the producer
> stopped after a small number of messages until I increased the value to
> 50mb.
> 
>         <!-- Destination specific policies using destination names or
> wildcards -->
>         <destinationPolicy>
>             <policyMap>
>                 <policyEntries>
>                     <policyEntry queue=">" memoryLimit="5mb"/>
>                     <policyEntry topic=">" memoryLimit="5mb">
>                     </policyEntry>
>                 </policyEntries>
>             </policyMap>
>         </destinationPolicy>
> 
> 
> RakeshRay wrote:
>> 
>> I tried with 1000 messsages or 800 byte/each, that is small enough.
>> I removed can_read before read_frame and seems behaving okay. Reading
>> more to figure out if can_read is really required in my case or not!
>> Thanks for the other suggestions, though.
>> 
>> mjustin wrote:
>>> 
>>> I am using 5.2 and 5.3-Snapshot. Have you tried to test it with a
>>> smaller number of messages, and without transactions? 
>>> 
>>> 
>>> RakeshRay wrote:
>>>> 
>>>> 
>>>> Hi, 
>>>> We have written a wrapper around and internally it is using using
>>>> timeout feature.
>>>> What version of Active MQ are you using?
>>>> 
>>>> 
>>> 
>>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Queue-does-not-drain-completely.-tp24296039p24427058.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message