activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Compiling ActiveMQ-CPP fails under Debian 4.0
Date Tue, 07 Jul 2009 14:54:07 GMT

Hi,

sudo apt-get install build-essential

should solve this problem (hopefully)

Cheers
Dejan



Timothy Bish wrote:
> 
> There could have been some issue introduced in the configure files when
> we converted everything over to using the APR libraries.  At least on
> all the systems that we are able to access, the library builds fine. You
> may need to compare the previous configure.ac file to the new one and
> see if you can find a change that is causing libpthread not to be found
> on debian.
> 
> On Mon, 2008-08-04 at 17:19 -0700, oliverw wrote:
>> By the way. The older version ActiveMQ-CPP 2.1.3 does not suffer from the
>> same problem. Configure at least completes without errors - stating
>> libpthread is installed so it must be something with ActiveMQ-CPP 2.2.
>> But I
>> had to fix a whole bunch of compile errors. All of them missing includes:
>> 
>> #include <string.h> was missing in:
>> 
>> /main/activemq/io/DataInputStream.cpp
>> /main/activemq/io/BufferedInputStream.cpp
>> /main/activemq/io/BufferedOutputStream.cpp
>> /main/activemq/connector/stomp/commands/CommandConstants.cpp
>> /main/activemq/util/Guid.cpp
>> 
>> #include <stdlib.h> was missing in:
>> /main/activemq/connector/stomp/StompCommandReader.cpp
>> 
>> 
>> 
>> 
>> oliverw wrote:
>> > 
>> > The latest version of libc6-dev is installed. AFAIK glibc-devel does
>> not
>> > exist in Debian.
>> > 
>> > 
>> > bsnyder wrote:
>> >> 
>> >> On Mon, Aug 4, 2008 at 10:08 AM, oliverw <oliver@weichhold.com> wrote:
>> >>>
>> >>> ./configure fails for activemq-cpp-2.2 under Debian 4.0 etch using
>> the
>> >>> latest
>> >>> packages from /testing with:
>> >>>
>> >>> checking for pthread_create in -lpthread... no
>> >>> configure: error: libpthread not found!
>> >>>
>> >>> Installing libpthread-stubs0-dev did not solve the problem.
>> Suggestions?
>> >> 
>> >> Do you have the glibc-devel or libc6-dev packages installed?
>> >> 
>> >> Bruce
>> >> -- 
>> >> perl -e 'print
>> >> unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
>> >> );'
>> >> 
>> >> Apache ActiveMQ - http://activemq.org/
>> >> Apache Camel - http://activemq.org/camel/
>> >> Apache ServiceMix - http://servicemix.org/
>> >> 
>> >> Blog: http://bruceblog.org/
>> >> 
>> >> 
>> > 
>> > 
>> 
> 
> 
> 


-----
Dejan Bosanac

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net
-- 
View this message in context: http://www.nabble.com/Compiling-ActiveMQ-CPP-fails-under-Debian-4.0-tp18814306p24374568.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message