activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mjustin <michael.jus...@gmx.net>
Subject Re: Queue does not drain completely.
Date Thu, 02 Jul 2009 15:28:05 GMT

If it depends on message number / message size, maybe the broker needs more
buffer space, you can try increasing the memoryLimit in the activemq.xml
file. It helped with a similar problem where the producer stopped after a
small number of messages until I increased the value to 50mb.

        <!-- Destination specific policies using destination names or
wildcards -->
        <destinationPolicy>
            <policyMap>
                <policyEntries>
                    <policyEntry queue=">" memoryLimit="5mb"/>
                    <policyEntry topic=">" memoryLimit="5mb">
                    </policyEntry>
                </policyEntries>
            </policyMap>
        </destinationPolicy>


RakeshRay wrote:
> 
> I tried with 1000 messsages or 800 byte/each, that is small enough.
> I removed can_read before read_frame and seems behaving okay. Reading more
> to figure out if can_read is really required in my case or not!
> Thanks for the other suggestions, though.
> 
> mjustin wrote:
>> 
>> I am using 5.2 and 5.3-Snapshot. Have you tried to test it with a smaller
>> number of messages, and without transactions? 
>> 
>> 
>> RakeshRay wrote:
>>> 
>>> 
>>> Hi, 
>>> We have written a wrapper around and internally it is using using
>>> timeout feature.
>>> What version of Active MQ are you using?
>>> 
>>> 
>> 
>> 
> 
> 


-----
Michael Justin
SCJP, SCJA
betasoft - Software for Delphi™ and for the Java™ platform
http://www.mikejustin.com - http://www.betabeans.de
-- 
View this message in context: http://www.nabble.com/Queue-does-not-drain-completely.-tp24296039p24308863.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message