activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From chu_man_fu <...@bytron.com>
Subject Using Oracle for persistence - DB sessions not dying
Date Thu, 02 Jul 2009 13:20:21 GMT

I am using oracle as my persistence store. ActiveMQ is running via
activemq-web-console-5.2.0.war which is embedded into JBoss 4.2.2GA on a
linux box.

The config is thus:

<persistenceAdapter>
   <journaledJDBC dataSource="#oracle-ds" useDatabaseLock="false">
      <statements>
         <statements tablePrefix="MSG_SER_ACTMQ_" />
     </statements>
   </journaledJDBC>
</persistenceAdapter>

    <bean id="oracle-ds" class="org.apache.commons.dbcp.BasicDataSource"
destroy-method="close">
      <property name="driverClassName"
value="oracle.jdbc.driver.OracleDriver"/>
      <property name="url" value="jdbc:oracle:oci:@MY_DB"/>
      <property name="username" value="scott"/>
      <property name="password" value="tiger"/>
      <property name="maxActive" value="200"/>
      <property name="poolPreparedStatements" value="true"/>
    </bean>

Which works. 
The only problem is my DBA. I left the JBoss running last night with no
message producers running.
When I got into work this morning he wanted to know why there is a java
process on my linux box with has taken 100+ oracle sessions. Once I stopped
JBoss (and the broker) all the sessions died and my DBA was happy again.

Why isn't ActiveMQ killing the sessions once they are used?
Am I missing a config setting?

Thanks
Chris
-- 
View this message in context: http://www.nabble.com/Using-Oracle-for-persistence---DB-sessions-not-dying-tp24306601p24306601.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message