activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruce Snyder <bruce.sny...@gmail.com>
Subject Re: activemq persisting to Postgres 8.1
Date Mon, 22 Jun 2009 13:07:49 GMT
On Mon, Jun 22, 2009 at 7:02 AM, jet3723<jet3723@gmail.com> wrote:
>
> Product: Activemq 5.2
>
> I'm having an issue with activemq creating tables when Postgres 8.1 is the
> persistence database. The error that I get is this:
> WARNING: Could not create JDBC tables; they could already exist. Failure
> was: CREATE TABLE ACTIVEMQ_MSGS(ID INTEGER NOT NULL
> , CONTAINER VARCHAR(250), MSGID_PROD VARCHAR(250), MSGID_SEQ INTEGER,
> EXPIRATION BIGINT, MSG BLOB, PRIMARY KEY ( ID ) ) Mess
> age: ERROR: type "blob" does not exist SQLState: 42704 Vendor code: 0
>
> I've tried using the defaultJDBCAdapter and the bytesJDBCAdapter. Any hints
> would be appreciated.

Have you tried the PostregresqlJDBCAdapter? It is used by default when
you configure a bean to persist to PostgreSQL. See the example in the
conf/activemq.xml.

Bruce
-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

ActiveMQ in Action: http://bit.ly/2je6cQ
Blog: http://bruceblog.org/
Twitter: http://twitter.com/brucesnyder

Mime
View raw message