activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zfbrad <brad.robert...@zerofootprint.net>
Subject Re: I can not start activemq on Red hat Linux 64 bits computer, looks like can not found log4j......
Date Mon, 29 Jun 2009 15:44:47 GMT

Did you figure out what was going on here?  I'm running OSX and I have the
same exception. Seems to not be able to find log4j even though it's in the
activemq directory.  


Websphere and ActiveMQ wrote:
> 
> Yes. log4j jar file is there.
> 
> 
> bsnyder wrote:
>> 
>> On Tue, May 12, 2009 at 2:42 PM, Websphere and ActiveMQ
>> <derrickcui@hotmail.com> wrote:
>>>
>>> [root@cardisdev2 apache-activemq-5.2.0]# ./bin/activemq
>>> ACTIVEMQ_HOME: /opt/apache-activemq-5.2.0
>>> ACTIVEMQ_BASE: /opt/apache-activemq-5.2.0
>>> Loading message broker from: xbean:activemq.xml
>>> ERROR: java.lang.RuntimeException: Failed to execute start task. Reason:
>>> java.io.IOException: Could not load xbean
>>> factory:java.lang.ExceptionInInitializerError
>>> java.lang.RuntimeException: Failed to execute start task. Reason:
>>> java.io.IOException: Could not load xbean
>>> factory:java.lang.ExceptionInInitializerError
>> ...
>>> Caused by: java.lang.NoClassDefFoundError: org/apache/log4j/Logger
>> 
>> The Log4J JAR (log4j-1.2.14.jar) file should be in the lib/optional
>> directory. Do you have that in your ActiveMQ lib/optional directory?
>> 
>> Bruce
>> -- 
>> perl -e 'print
>> unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
>> );'
>> 
>> ActiveMQ in Action: http://bit.ly/2je6cQ
>> Blog: http://bruceblog.org/
>> Twitter: http://twitter.com/brucesnyder
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/I-can-not-start-activemq-on-Red-hat-Linux-64-bits-computer%2C-looks-like-can-not-found-log4j......-tp23510018p24256596.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message