activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From benjamine <nidhinbenja...@gmail.com>
Subject SSL communication Failure - ActiveMQ
Date Wed, 17 Jun 2009 15:40:35 GMT

HI All,

   To Configure SSL communication I am following the below URL from activeMQ
http://activemq.apache.org/how-do-i-use-ssl.html

   I followed all the steps which is mentioned in the above url
   This is my configuration

    <amq:sslContext>
                              <amq:sslContext
                              keyStore="broker.ks"
keyStorePassword="pass123"
                              trustStore="client.ts"
trustStorePassword="pass123"/>
                            </amq:sslContext>
                            <amq:transportConnectors>
                              <amq:transportConnector
uri="ssl://localhost:61625" />
                            </amq:transportConnectors>


>From the client side i am following all the steps which is mentioned in the
list.

kerstore which i am setting in the client side  : client.ks ( tried with
broker.ks also)
trustedstore client.ts

06-17 10:35:25 [ActiveMQ Transport Initiator: /172.20.106.64:4050] ERROR
(org.apache.activemq.broker.TransportConnector$1:onAcceptError)     - Could
not accept connection : Received fatal alert: certificate_unknown

would you please let me know where i am wrong.

Thanks in advance.
Ben 
-- 
View this message in context: http://www.nabble.com/SSL-communication-Failure---ActiveMQ-tp24076365p24076365.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message