activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "akbar.gadhiya" <akbar.gadh...@gmail.com>
Subject Multiple consumers, message sent but not consumed
Date Tue, 16 Jun 2009 09:54:39 GMT

Hi,

I am using activemq-5.1. ActiveMQ is embedded in my spring project. I have 1
producer and 5 consumers in the application. When I started performing load
test for the application, after few hours I noticed that one consumer
stopped processing messages and this happen with all five consumers. I have
visited the forum but I couldn't conclude anything. 

JConsole gives following statistics for the consumer which has stopped
receiving/ processing messages.

Active: true
DequeueCounter                          : 25831
DispatchedCounter                       : 26832
DispatchedQueueSize                    : 1001
EnqueueCounter                           : 28388
MessageCountAwaitingAcknowledge : 1001
Durable                                       : false
PrefetchSize                                : 1000
PendingQueueSize                         : 49

Following is the configuraation for embedding activemq.

......
	<bean id="jmsFactory"
class="org.apache.activemq.ActiveMQConnectionFactory">
		<property name="brokerURL" value="vm://localhost"/>
	</bean>

	<bean id="myJmsTemplate" class="org.springframework.jms.core.JmsTemplate">
		<property name="connectionFactory">
			<bean class="org.springframework.jms.connection.SingleConnectionFactory">
				<property name="targetConnectionFactory">
					<ref local="jmsFactory"/>
				</property>
			</bean>
		</property>
		<property name="pubSubDomain">
			<value>true</value>
		</property>
	</bean>
......


Any help would be highly appreciated.

thanks & regards,
Akbar G.

-- 
View this message in context: http://www.nabble.com/Multiple-consumers%2C-message-sent-but-not-consumed-tp24051128p24051128.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message