activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francois Staes <fst...@netconsult.be>
Subject Inconsistency between queue length and queue browsing
Date Fri, 12 Jun 2009 06:10:32 GMT


Hello,

I'm facing an inconsistency in the behaviour of ActiveMQ for which I cannot
find an easy explanation.

The facts:

$ ./activemq-admin query  -QQueue=provRequests1
DequeueCount = 0
Name = provRequests1
MinEnqueueTime = 259749107
CursorMemoryUsage = 2905853
MaxAuditDepth = 2048
Destination = provRequests1
AverageEnqueueTime = 2.650460257689655E8
InFlightCount = 0
MemoryLimit = 67108864
Type = Queue
EnqueueCount = 0
MaxEnqueueTime = 771219376
MemoryUsagePortion = 1.0
ProducerCount = 0
UseCache = true
MaxProducersToAudit = 1024
CursorFull = false
BrokerName = localhost
ConsumerCount = 0
ProducerFlowControl = true
Subscriptions = [Ljavax.management.ObjectName;@8e4327
QueueSize = 7778
MaxPageSize = 200
CursorPercentUsage = 4
MemoryPercentUsage = 4
DispatchCount = 1160

So, there are 7778 messages on the queue.

On the other hand:

$  ./activemq-admin browse --amqurl tcp://localhost:61616  provRequests1  |
grep JMSMessageID |wc
     517    1551   47045

Implying there are only 517 messages on the queue.

How to explain this difference ?

Environment:

- ActiveMQ 5.1.0 or 5.2.0 (same behaviour in both)
- Default persistency setup

Regards,

Francois Staes.
-- 
View this message in context: http://www.nabble.com/Inconsistency-between-queue-length-and-queue-browsing-tp23993379p23993379.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message