activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gsm2a <gs...@yahoo.com>
Subject Subscriber not detecting the lost connection
Date Mon, 08 Jun 2009 19:52:51 GMT

I am running into a very weird problem.
I have a publisher and a subscriber on one box pointing to ActiveMQ runinng
as a webapp under tomcat on another machine. 

-- Both publisher and subscriber are on Box A, each has their own tcp
connection. They both are using failover protocol. I need to make a nore
here that I am just using the failover protocol to hold the connections
during the network problems. So, my failover protocol only contains one
activeMQ server machine.

-- Tomcat(ActiveMQ webapp) is running on Box B. Box B is in a passive
Microsoft OS cluster with 2 nodes configured in it. Node 1 and Node2. tomcat
is running on any one node at any given point of time.

-- Publisher and Subscriber on Box A are using cluster IP address. The
cluster IP addess points to currently active node

-- When I move the Tomcat service ( in effect moving the activemq) from Node
1 to Node 2, Tomcat service on Node 1 goes offline and Tomcat on Node 2
comes online. 

-- When 'Move' happens, I see connetion exception for publisher and I see a
messging in the activeMQ client log saying "Attempting connect to:
tcp://...".  I do not see the same for the subscriber connection.

-- I do not see the subscriber connection in the activemq webconsole after
the move occurs( tomcat comes conline on node 2)

-- It just seems like the subscriber never recognized the connection lost
and therefore never attempted to reconnect.

I tried the same with non-failover protocol for Subscriber. Event then, it
didnt recognize the connection lost and never kicked in the onException().

 I tried the same in a normal non-clustered environment  and i do see
connection lost is detected and the failover protocol automatically
reconnects and everything works fines except in the above scenario.

I have been struggling with this problem for a while. Could anyone please
suggest any ideas on how to process further with this? I am kind of stuck on
this...please help!

Thanks in advance!
Gary.

 




-- 
View this message in context: http://www.nabble.com/Subscriber-not-detecting-the-lost-connection-tp23930972p23930972.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message