activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From david256 <da...@digitaltrowel.com>
Subject Re: Encoding proble when sending from c# producer
Date Mon, 08 Jun 2009 12:11:34 GMT

I have tested it again without spring.
The locale on the producer vista machine is en_us.
The problem persists


Timothy Bish wrote:
> I 
> On Mon, 2009-06-08 at 03:40 -0700, david256 wrote:
>> Thanks for the reply
>> I am using Spring.Messaging.Nms.Listener 
> 
> Have you tried it with a straight C# consumer to remove the Sprint.Net
> code from the equation?
> 
> Regards
> Tim
> 
>> 
>> Timothy Bish wrote:
>> > 
>> > On Sun, 2009-06-07 at 08:23 -0700, david256 wrote:
>> >> Hi,
>> >> 
>> >> I am using activemq 5.2.0 which runs on an ubuntu machine with jdk6.
>> >> 
>> >> I have built a C# producer client which communicates via NMS with the
>> >> broker. The C# producer runs on a vista machine.
>> >> 
>> >> I am using it to transfer text messages.
>> >> All works well, but when the text contains a character from a group of
>> >> chars, and I view it in the admin web app they appear as '?' for
>> example:
>> >> 
>> >> original text: "PATA’s Industry Council"
>> >> 
>> >> The text when it is consumed: "PATA?s Industry Council"
>> >> 
>> >> I debugged it, and  examined the text before it is sent to the broker
>> in
>> >> the
>> >> visual studio watches, and it looked perfect. When I examined the
>> message
>> >> in
>> >> the consumer it replaced the ' ’ ' with ' ? '
>> >> 
>> >> Does anyone has any hint as to why I get this encoding problem?
>> > 
>> > Its possible there's a bug in our string marshaling code.  What client
>> > are you consuming the Message with, Java? C#? etc?  
>> > 
>> > You should open a Jira issue for this and attach any small complete
>> test
>> > code you have to reproduce the problem.
>> > 
>> > Regards
>> > Tim.
>> > 
>> > -- 
>> > Tim Bish
>> > http://fusesource.com
>> > http://timbish.blogspot.com/
>> > 
>> > 
>> > 
>> > 
>> > 
>> 
> -- 
> Tim Bish
> http://fusesource.com
> http://timbish.blogspot.com/
> 
> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Encoding-proble-when-sending-from-c--producer-tp23912044p23922859.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message