activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Gomes" <e.se...@gmail.com>
Subject Re: Discovery and NMS
Date Thu, 11 Jun 2009 01:48:43 GMT
Eric,

Thanks for trying that out. At this point there isn't much more to try out since Tim has also
confirmed that discovery is not working. We will push this out to the next version of NMS
because we want to get 1.1 shipped. I don't think the next version will take as long as this
one and discovery is the first major feature scheduled to be worked on. However if we are
able to find a simple fix that can be thrown in during the release phase, I'm sure it can
be considered.


- Jim

-----Original Message-----
From: Eric Bouer <ericbouer@gmail.com>

Date: Wed, 10 Jun 2009 14:21:37 
To: <users@activemq.apache.org>
Subject: Re: Discovery and NMS



Hello Jim
Unfortunately I can't confirm it's working
Using  activemq:failover 
(discovery:multicast://default,tcp://activemqhost:61616)
I've got :
"Connect fail to 'discovery:multicast://default': Composite connection not 
supported with MulticastDiscovery transport."

Using activemq:discovery:multicast://default I've got:

Connect failed :Apache.NMS.NMSConnectionException: Unable to find a
connection 
to discovery:multicast://default before the timeout period expired.
   at 
Apache.NMS.ActiveMQ.Transport.Discovery.DiscoveryTransportFactory.CreateTransport(Uri 
location)
   at Apache.NMS.ActiveMQ.Transport.TransportFactory.CreateTransport(Uri 
location)
   at Apache.NMS.ActiveMQ.ConnectionFactory.CreateConnection(String
userName, 
String password)
   at Apache.NMS.ActiveMQ.ConnectionFactory.CreateConnection()
   at ActiveMQConnector.MQ.Connect()

Tried again trunk from today.
Can I help you with more information or anything else?
Thanks.
Eric.



semog wrote:
> 
> Hi Eric (And John West),
> 
> I haven't been able to get the auto-discovery to work yet, but from your
> sample connection strings, I think you will need to change them to the
> following to have any chance of getting them to work:
> 
> activemq:discovery:multicast://default
> 
> or
> 
> activemq:failover:discovery:multicast://default
> 
> Parenthesis are also acceptable as follows:
> 
> activemq:discovery:(multicast://default)
> activemq:failover:(discovery:multicast://default,tcp://activemqhost:61616)
> 
> The key is to have the prefix of "activemq:".  If you don't have that,
> then the correct connection factory will not be loaded by NMS.  Make sure
> you update to the latest code and rebuild the Apache.NMS and
> Apache.NMS.ActiveMQ projects before trying anything.  The discovery
> protocol stuff is not my area of expertise, so I'm still attempting to
> figure out the mechanisms behind it.
> 
> Best,
> Jim
> 

-- 
View this message in context: http://www.nabble.com/Discovery-and-NMS-tp22812691p23971301.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message