activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nawaz Ahmed" <>
Subject Observations from Master Slave setup
Date Thu, 21 May 2009 09:02:56 GMT
Hi ,


I was trying to configure a pure master slave configuration with Fuse
Message broker . First I tried without security. I created two
brokers in different machines. The transport connectors looked like


 <transportConnector name="openwire" uri="tcp://machine_name:61720"
discoveryUri="multicast://default" />


This configuration worked fine.


After this I tried with security.


I gave master brokers transport connector as <transportConnector
name="openwire" uri="tcp://machine_name:61720"
discoveryUri="multicast://default" />.

Then I configured a simple authentication plugin as follows.





                                <authenticationUser username="system"


                                <authenticationUser username="user"


                                <authenticationUser username="guest"
password="password" groups="guests"/>





After doing this the master broker didn't start. I threw security
exception that passwords don't match. But when I changed the transport
connector to <transportConnector name="openwire"
uri="tcp://localhost:61720"  discoveryUri="multicast://default" /> it
started fine. 


After this the slave broker in another machine could not connect to the
master. It threw connection refused exception. But when I configured the
slave in the same machine as master with different port numbers for
transport connectors  it successfully attached itself with the master.


Finally I removed the discoveryUri="multicast://default" from the
transport connectors. Then everything worked fine. The master slave got
working in two different machines with machine names in their transport
connectors URI.


>From the following observations I have a few questions:


1.       Why the broker throws a security exception of User name or
password is invalid if I use the following transport connector.

               <transportConnector name="openwire"
uri="tcp://machine_name:61720"  discoveryUri="multicast://default" />.

2.       Why the exception vanishes if I use localhost  instead of
machine name.

3.       Even if the master starts with localhost the slave in other
machine gets connection refused exception.

4.       When I remove the discovery URI from the transport connectors
everything works fine.


Any suggestions on this will be appreciated.



Nawaz Ahmed


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message