activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jose Luna <j-l...@rocketmail.com>
Subject Re: No way to use activeMQ via http. TCP works fine, but not http. Please help.
Date Mon, 04 May 2009 19:43:51 GMT


> Jose Luna-2 wrote:
> > 
> > I don't have any recommendation regarding activemq and HTTP but you may
> > consider tunneling openwire through SSL
> > (http://activemq.apache.org/ssl-transport-reference.html).    If you set
> > your broker up to use port 443, proxies won't be able to distinguish
> > between this traffic and HTTPS, so the traffic will be allowed to pass
> > through.   Actually, you would be able to get away with running the
> > traffic over port 443 without using the SSL transport, but that somehow
> > seems more deceptive ;) .   For more info, see
> > http://tools.ietf.org/html/draft-luotonen-web-proxy-tunneling-01 .
> > 
> >    
> > 
> > 
> Thank you for your reply, sir.
> Other words, you telling I may use 443 port via tcp. An my clients will be
> able to connect to server through this port even if they under the proxy.
> Correct?
> 
> Any way, guys, could you provide me other solutions, please.
> 
> Thank you.


Yes.  It's just a suggestion that I thought you might find useful.  You will need to be able
to do the HTTPS handshake (see the ietf.org link I sent in my previous email).  You will also
need to be able handle proxy authentication for users that requrie it, but that's something
you would have to handle anyway if you are dealing with proxies.



      

Mime
View raw message