activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richie84 <richiejame...@aim.com>
Subject Master Slave authentication - fail to authenticate but still connects
Date Tue, 19 May 2009 14:49:08 GMT

Hi all,

I have searched through previous posts, and although there are related
posts, people seemed to have had the opposite issue to what I am having so
heres a new post!

It comes down to my master/slave configuration, which works fine, until you
add the authentication ingredient in. I am encountering problems with both a
simple authentication plugin and a jaas plugin.

When a slave tries to attach itself to the master (using incorrect or no
credentials), the master dislikes it and throws a few errors which seems
positive as this is what i want, however it then proceeds in allowing the
slave to attach, and this is where its lost me. The master does seem to be
unhappy that slave with bad credentials is trying to connect, but it still
goes a head and lets it. Below are the errors messages for a simple
authentication plugin

WARN  TransportConnection            - Failed to add Connection
java.lang.SecurityException: User name or password is invalid.
        at
org.apache.activemq.security.SimpleAuthenticationBroker.addConnection(SimpleAuthenticationBroker.java:52)
        at
org.apache.activemq.broker.MutableBrokerFilter.addConnection(MutableBrokerFilter.java:89)
        at
org.apache.activemq.broker.TransportConnection.processAddConnection(TransportConnection.java:679)
        at
org.apache.activemq.broker.jmx.ManagedTransportConnection.processAddConnection(ManagedTransportConnection.java:86)
        at
org.apache.activemq.command.ConnectionInfo.visit(ConnectionInfo.java:125)
        at
org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:305)
        at
org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:179)
        at
org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:68)
        at
org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:143)
        at
org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:206)
        at
org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:84)
        at
org.apache.activemq.transport.tcp.TcpTransport.doRun(TcpTransport.java:203)
        at
org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:185)
        at java.lang.Thread.run(Thread.java:619)
ERROR Service                        - Async error occurred:
java.lang.SecurityException: User name or password is invalid.
java.lang.SecurityException: User name or password is invalid.
        at
org.apache.activemq.security.SimpleAuthenticationBroker.addConnection(SimpleAuthenticationBroker.java:52)
        at
org.apache.activemq.broker.MutableBrokerFilter.addConnection(MutableBrokerFilter.java:89)
        at
org.apache.activemq.broker.TransportConnection.processAddConnection(TransportConnection.java:679)
        at
org.apache.activemq.broker.jmx.ManagedTransportConnection.processAddConnection(ManagedTransportConnection.java:86)
        at
org.apache.activemq.command.ConnectionInfo.visit(ConnectionInfo.java:125)
        at
org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:305)
        at
org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:179)
        at
org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:68)
        at
org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:143)
        at
org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:206)
        at
org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:84)
        at
org.apache.activemq.transport.tcp.TcpTransport.doRun(TcpTransport.java:203)
        at
org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:185)
        at java.lang.Thread.run(Thread.java:619)
INFO  TransportConnection            - Slave Broker Slave_Broker is attached

When trying the JAAS authentication, similar output is provided just with
the appropriate jaas errors in. To confirm the slave is attached, if i send
messages to the master, these are replicated to the slave. 

So i'm not sure where i am going wrong, just to clarify using both JAAS and
the simple authentication it works when controlling who can send/receive
messages to queues/topics, it just seems to be hitting problems with
connecting brokers. I have attached the activemq.xml file (the jaas part is
currently commented out). 

http://www.nabble.com/file/p23617914/activemq.xml activemq.xml 

Any clues or pointers to why the above might be happening would be great

Cheers

Richard


-- 
View this message in context: http://www.nabble.com/Master-Slave-authentication---fail-to-authenticate-but-still-connects-tp23617914p23617914.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message