activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fehm <Felix....@cern.ch>
Subject Re: Installing DLQ Broker plugin (interceptor) for 5.3.0
Date Mon, 18 May 2009 08:06:54 GMT

Hi,

sometimes opening the eyes a bit more have great effect. Indeed, I missed
out the correct name of the class to use.


Thanks a lot!
Felix



Jose Luna-2 wrote:
> 
> 
> 
> 
> 
> 
> ----- Original Message ----
>> From: fehm <Felix.Ehm@cern.ch>
>> To: users@activemq.apache.org
>> Sent: Friday, May 15, 2009 7:25:57 AM
>> Subject: Installing DLQ Broker plugin (interceptor) for 5.3.0
>> 
>> 
>> Hi,
>> 
>> I have some difficulties installing the DLQ broker plugin as stated on
>> the
>> plugin installation howto page : 
>> http://activemq.apache.org/interceptors.html . Does somebody has the
>> correct
>> way how to do this ?
>> 
>> I thought this is enough :
>> 
>> ..
>> 
>>     
>> class="org.apache.activemq.plugin.DiscardingDLQBroker">
>>       
>>       
>>       
>>     
>>   
>> 
>> 
>> but then I get :
>> Failed to execute start task. Reason:
>> org.springframework.beans.factory.BeanDefinitionStoreException:
>> Unrecognized
>> xbean element mapping: bean in namespace
>> http://activemq.apache.org/schema/core
>> 
>> 
>> 
>> and if I add the schema location for the spring bean:
>> 
>> 
>>     
>> id="discardingDlqBroker"
>> class="org.apache.activemq.plugin.DiscardingDLQBroker">
>>       
>>       
>>       
>>     
>>   
>> 
>> 
>> it gives :
>> org.springframework.beans.factory.BeanCreationException: Error creating
>> bean with name 'discardingDlqBroker' defined in file
>> [/tmp/jms-inca1-pro/conf/jms-inca1-pro.xml]: Instantiation of bean
>> failed;
>> nested exception is org.springframework.beans.BeanInstantiationException:
>> Could not instantiate bean class
>> [org.apache.activemq.plugin.DiscardingDLQBroker]: No default constructor
>> found; nested exception is java.lang.NoSuchMethodException:
>> org.apache.activemq.plugin.DiscardingDLQBroker.()
>> 
>> 
>> http://www.nabble.com/file/p23557866/broker.xml broker.xml 
>> 
>> 
>> Thanks in advance,
>> Felix
>> -- 
>> View this message in context: 
>> http://www.nabble.com/Installing-DLQ-Broker-plugin-%28interceptor%29-for-5.3.0-tp23557866p23557866.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> 
> Changing the xmlns was correct, this resolved your namespace problem.  The
> next issue is that you're trying to install an instance of BrokerFilter
> instead of BrokerPlugin.  The broker plugin uses the installPlugin method
> to hook in the BrokerFilter, so you should use this class: 
> http://people.apache.org/~gtully/staging-sites/activemq-5.2.0/maven/5.2.0/activemq-core/apidocs/org/apache/activemq/plugin/DiscardingDLQBrokerPlugin.html
> .  In other words:
> 
> class="org.apache.activemq.plugin.DiscardingDLQBrokerPlugin"
> 
> I assume you used the example here:
> http://issues.apache.org/activemq/browse/AMQ-1892 (that's the only
> reference I could find) . That means this example is wrong, would you mind
> making a comment and updating it after you confirm that this fixes the
> problem?
> 
> 
>       
> 
> 

-- 
View this message in context: http://www.nabble.com/Installing-DLQ-Broker-plugin-%28interceptor%29-for-5.3.0-tp23557866p23592924.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message