activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yaswanth <yaswanth.m...@gmail.com>
Subject Re: Publishing to Topic is very slow in higher loads ActiveMQ5.2.
Date Thu, 14 May 2009 12:33:48 GMT


Hi, 

Thanks for the reply . 

When observed in Broker Statistics in Jconsole it has enough memory. 

Here is my ActiveMQ.xml file .. 
http://www.nabble.com/file/p23539624/activemq.xml activemq.xml 

Here is the Memory Snapshot of ActiveMQ Old Generation.  
http://www.nabble.com/file/p23539624/OldGen.JPG OldGen.JPG 




Gary Tully wrote:
> 
> can you give more memory resources to the broker? I imagine there is
> some spooling to disk under high load. It may make sense to post your
> activemq.xml.
> 
> 2009/5/14 KumarR <rykumar7@gmail.com>:
>>
>> Hi All ,
>>
>> I am having problem with publishing messages to Topic. It's taking too
>> much
>> time to publish a message. Below are the details.
>>
>> Test Case:
>>
>> The Client  is publishing messages to RequestQueue. and waiting responses
>> on
>> ResponseTopic using a co-relation id.
>> Server program consuming messages from RequestQueue using Spring Message
>> POJOs. These POJOs after consuming and processing the messages,
>> forms the response message and publishes to the ResponseTopic using
>> co-relationid.
>> The client using blocked receive(TIMEOUT) receive responses from
>> ResponseTopic using Message selector with co-relation id.
>>
>>
>> Observations: at higher loads, around 3000 conc users, the publishing
>> response messages back to Response Topic becoming slow;
>> taking around 5 secs to 10 secs. otherwise in 2000 conc users load, it
>> was
>> taking around 100 ms-120 ms.
>>
>> Setup Configuration:
>> We are using ActiveMQ 5.2 on Sun Solaris 10 - SPARC JVM 1.6_16;
>> Topic has Non-Durable Consumer;  we use Non-Transactional, Non-Persistent
>> Messages
>>
>> Client program is a WebApplication running on JBoss-JVM instance on
>> server
>> machine 1
>> ActiveMQ is a standalone broker jvm running on server machine 2
>> Server program is another backend application (not web-application) on
>> another Jboss-JVM instance on server machine2.
>>
>>
>> Can any one help in solving this problem ?
>>
>> Thanks
>> Kumar
>>
>> -----
>> Thanks,
>> Kumar Ravella
>> --
>> View this message in context:
>> http://www.nabble.com/Publishing-to-Topic-is-very-slow-in-higher-loads-ActiveMQ5.2.-tp23538009p23538009.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> 
> -- 
> http://blog.garytully.com
> 
> Open Source SOA
> http://FUSESource.com
> 
> 

-- 
View this message in context: http://www.nabble.com/Publishing-to-Topic-is-very-slow-in-higher-loads-ActiveMQ5.2.-tp23538009p23539624.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message