activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ren0 <renaud.deys...@thalesgroup.com>
Subject Re: Performance module: cannot load custom broker config
Date Tue, 21 Apr 2009 14:09:48 GMT

Hi frederic,

I have the same problem.
How did you manage to fix this problem

Regards

Renaud




fredrick255 wrote:
> 
> Using the default broker config I get an error message that there are too
> many open files when I try to produce to 1000 topics.
> 
> I am not able to load any other configuration files.
> If I give the url argument with the configType argument it seems to get
> ignored:
> mvn activemq-perf:broker -Durl=broker:tcp://localhost:61616
> -DconfigType=memory
> 
> I still get this message when it loads up:
> INFO: Using Persistence Adapter:
> AMQPersistenceAdapter(activemq-data/localhost)
> Aug 21, 2008 9:30:39 AM org.apache.activemq.broker.BrokerService getBroker
> 
> 
> If I do it with out the URL argument I get:
> [root@Zaurac activemq-perftest]# mvn activemq-perf:broker
> -DconfigType=memory
> [INFO] Scanning for projects...
> [INFO] Searching repository for plugin with prefix: 'activemq-perf'.
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building ActiveMQ :: Performance Test
> [INFO]    task-segment: [activemq-perf:broker]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] [activemq-perf:broker]
> ACTIVEMQ_HOME: /root/.m2/repository/org/apache/activemq/activemq-console
> ACTIVEMQ_BASE: /root/.m2/repository/org/apache/activemq/activemq-console
> Loading message broker from:
> xbean:file:/root/j/svn3/activemq-5.1.0/activemq-perftest/target/activemq.xml
> ERROR: java.lang.RuntimeException: Failed to execute start task. Reason:
> java.io.IOException: Could not load xbean
> factory:java.lang.NoClassDefFoundError:
> org/springframework/core/io/FileSystemResource
> java.lang.RuntimeException: Failed to execute start task. Reason:
> java.io.IOException: Could not load xbean
> factory:java.lang.NoClassDefFoundError:
> org/springframework/core/io/FileSystemResource
>         at
> org.apache.activemq.console.command.StartCommand.runTask(StartCommand.java:98)
>         at
> org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:57)
>         at
> org.apache.activemq.console.command.ShellCommand.runTask(ShellCommand.java:129)
>         at
> org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:57)
>         at
> org.apache.activemq.console.command.ShellCommand.main(ShellCommand.java:79)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:597)
>         at org.apache.activemq.console.Main.runTaskClass(Main.java:222)
>         at org.apache.activemq.console.Main.main(Main.java:106)
>         at
> org.apache.activemq.maven.ServerMojo.execute(ServerMojo.java:107)
> .......
> 
> 
> I get the same behavior with the -DconfigFile argument.
> 
> Would JMeter because easier to configure for load testing 5.1?
> 
> Any ideas?
> 
> 
> 
> 
> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Performance-module%3A-cannot-load-custom-broker-config-tp19088894p23156945.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message