activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From magellings <mark.gelli...@qg.com>
Subject NMS 1.1 and failover protocol slowness
Date Mon, 13 Apr 2009 22:18:08 GMT

Hello.  Has anyone used the 1.1 binaries for NMS and NMS.ActiveMQ from trunk
and the failover: protocol?

I'm experiencing a lot of slowness and I've found at least one comment (on
item in issue tracker) stating the same.

http://issues.apache.org/activemq/browse/AMQNET-26?focusedCommentId=47183&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_47183


"Second, the recent changes to Apache.NMS.ActiveMQ's file
OpenWire/OpenWireFormat.cs create massive delays on my system. If I revert
that file back to the version 693666 (09-Sep-2008) then all my code starts
working without delays. It seems that the action of writing to the bus
(using Topics in my case) is delayed 120 seconds or so. Each write seems to
be delayed 15 seconds. Since startup involves several writes the initialize
the wire format, I suspect that a timeout variable is set to 0 (zero) which
does not allow a thread-swap to take place. So it hangs. I will create a new
issue for this problem.

Please test and give feedback. If it is positive, then Jim can commit the
change to the repository."

I've also noticed the Spring Messaging framework stalls when master and
slave brokers switch using the failover protocol.
-- 
View this message in context: http://www.nabble.com/NMS-1.1-and-failover-protocol-slowness-tp23028265p23028265.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message