activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From virtualshock <nab...@virtualshock.net>
Subject ActiveMQ 5.2.0 - Problem starting a BrokerService programmatically.
Date Thu, 02 Apr 2009 16:48:34 GMT

I am running ActiveMQ embedded in another application and it seems like it is
running correctly but broker.start() never returns which is hanging the
startup of my program.  In 4.x I didn't have this problem.
Here is a code snippet of how I am starting ActiveMQ :

            broker = new BrokerService();
            broker.setBrokerName(getInternalConnectionName());
            broker.getManagementContext().setCreateConnector(false);
            broker.setPersistent(true);
            broker.addConnector(getExternalConnectionURL());
            broker.start();

Here is the log output :

2009-04-02 11:14:42,884 [WrapperListener_start_runner] DEBUG
com.xxxx.agents.ActiveMQAgent - Starting ActiveMQAgent:tcp://localhost:61616
& vm://embeddedActiveMQBroker
2009-04-02 11:14:42,885 [WrapperListener_start_runner] INFO 
org.apache.activemq.broker.BrokerService - Using Persistence Adapter:
AMQPersistenceAdapter(activemq-data/embeddedActiveMQBroker)
2009-04-02 11:14:42,885 [WrapperListener_start_runner] WARN 
org.apache.activemq.store.amq.AMQPersistenceAdapter - Waiting to Lock the
Store activemq-data/embeddedActiveMQBroker
2009-04-02 11:15:01,837 [Persistence Adaptor Task] DEBUG
org.apache.activemq.store.amq.AMQPersistenceAdapter - Checkpoint started.
2009-04-02 11:15:01,838 [Persistence Adaptor Task] DEBUG
org.apache.activemq.store.amq.AMQPersistenceAdapter - Checkpoint done.
2009-04-02 11:15:11,836 [ActiveMQ Scheduler] DEBUG
org.apache.activemq.store.amq.AMQPersistenceAdapter -
dataFilesInProgress.values: (0) []
2009-04-02 11:15:11,836 [ActiveMQ Scheduler] DEBUG
org.apache.activemq.store.amq.AMQPersistenceAdapter - lastDataFile: 1
2009-04-02 11:15:11,837 [ActiveMQ Scheduler] DEBUG
org.apache.activemq.kaha.impl.async.AsyncDataManager - lastFileId=0,
purgeList: (0) []
2009-04-02 11:15:21,837 [Persistence Adaptor Task] DEBUG
org.apache.activemq.store.amq.AMQPersistenceAdapter - Checkpoint started.
2009-04-02 11:15:21,837 [Persistence Adaptor Task] DEBUG
org.apache.activemq.store.amq.AMQPersistenceAdapter - Checkpoint done.

Does anyone know what the problem is?

Thanks

-- 
View this message in context: http://www.nabble.com/ActiveMQ-5.2.0---Problem-starting-a-BrokerService-programmatically.-tp22851125p22851125.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message