activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Gottschalk <MGottsch...@gmx.net>
Subject Re: Messages getting Stuck
Date Wed, 01 Apr 2009 15:02:28 GMT
Hi Andy,

we also had similar problems with ActiveMQ 5.2 (see AMQ-2161).

This is apparently fixed in fuse 5.3.0.0, so we switched to fuse.
However, even with fuse, we had some additional problems, which we had to 
patch ourselves (namely an out-of-memory problem and a problem with 
interruptions). Our patches are available in the activemq JIRA (AMQ-2178 and 
AMQ-2191).

We still have one other problem (it occurred in activemq 5.2 and 
5.3.0.0-fuse): the camel processors were very slow in some cases when using 
JMS transactions and they just stopped polling messages when using XA 
transactions in some cases.
We could only fix that problem by replacing all camel processors by custom 
code that implements routing and polling directly with Spring JmsTemplates.

Cheers,
    Michael

Am Dienstag 31 März 2009 17:48:56 schrieb andymorris:
> Oh that's a shame. Have been trying OpenMQ but had some probs (namely
> http://forums.sun.com/thread.jspa?threadID=5377354&tstart=0) but I really
> can't believe there isn't a workaround for this - ActiveMQ is held in quite
> a high regard and is used quite a lot of commercial environments.
>
> Hmm, thanks for your reply, has anyone else experienced this (and hopefully
> solved it!)?
>
> krv wrote:
> > Hi Andy,
> >
> > Even after doing some research and tries I didn't succeed in my original
> > problem which is when I started looking for alternate solutions. OpenMQ
> > seem to suite our needs and helped us overcome this particular problem.
> > So, we went ahead with OpenMQ.
> >
> > But not sure if OpenMQ offers the features that you require. You can
> > check out its features and give it a try if it suits you.
> >
> > Again here, no offence to ActiveMQ users.
> >
> > Regards,
> > Vivek
> >
> > andymorris wrote:
> >> Hi guys/gals
> >>
> >> I know this is a fairly old post but I am experiencing exactly the same
> >> problem as described using version 5.2, so any bug may not have been
> >> fixed.
> >>
> >> After failover a load of messages (have seen up to 7000) get stuck, if I
> >> then restart the dead node and kill the new master (so switching back)
> >> then some of the messages get consumed, however this is only a few
> >> hundred or thousand and it gets stuck again. I keep switching broker
> >> node by restarting the dead one and killing the master and it tends to
> >> get through the remainding messages, but it tends to get to a few
> >> hundred left and no more restarting helps.
> >>
> >> My setup is:
> >> ActiveMQ 5.2 HA with two nodes master and slave.
> >> Java 6
> >> Spring 2.5
> >> Jencks to provide pooled connections (inbound and outbound)
> >> JmsTemplate
> >> Running from jar file (no appserver in this environment)
> >>
> >> FYI our company has used ActiveMQ for the last few years and has had
> >> quite a few problems (some their fault like putting 50mb files in
> >> messages!) and I'm meant to be looking at alternatives. I'd like to
> >> prove that if we use it properly and upgrade to the latest version that
> >> there'd be no/less significant problems.
> >>
> >> Any help would be greatly appreciated.
> >>
> >> andy
> [...]


Mime
View raw message